Skip to Content

disp+work.EXE (Dispatcher) - Running but Dialog Queue info unavailable,...

Hi gurus,

I´m facing with a weird problem in one system:

System: BI

D.B.: Oracle 10.2.0.2

S.O.: Win 2003 Server x64

I tried to do an upgrade to kernel (146 to 201). But after that I started the system in SAPMMC Console and that showed a weird thing. The ABAP WP Table don´t show any work process list and in Process List section the disp+work.EXE (Dispatcher)

is in yellow state/semaphore with status message "Running but Dialog Queue info unavailable, J2EE: All processes running"

I got to enter in system without any problem, I saw the tcode SM50 and all seems perfect! I took a look on Task Manager so that in that way I was able to see if the Work Process disp+work.exe got up or not, but all process was in there with normal memory usage!

So... I don´t know why this is in yellow state.. I already did a restart in sapmmc console but when I open it this problem persist!!

In next post/message I´ll put the dev_disp log file so with that you can see and help me what´s the problem...

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Aug 26, 2009 at 11:37 PM

    Here it is the log file DEV_DISP:

    -


    trc file: "dev_disp", trc level: 1, release: "700"

    -


    sysno 00

    sid BIP

    systemid 562 (PC with Windows NT)

    relno 7000

    patchlevel 0

    patchno 201

    intno 20050900

    make: multithreaded, Unicode, 64 bit, optimized

    pid 65996

    Wed Aug 26 22:09:42 2009

    kernel runs with dp version 242000(ext=110000) (@(#) DPLIB-INT-VERSION-242000-UC)

    length of sys_adm_ext is 576 bytes

        • SWITCH TRC-HIDE on ***

        ***LOG Q00=> DpSapEnvInit, DPStart (00 65996) [dpxxdisp.c 1287]

        shared lib "dw_xml.dll" version 201 successfully loaded

        shared lib "dw_xtc.dll" version 201 successfully loaded

        shared lib "dw_stl.dll" version 201 successfully loaded

        shared lib "dw_gui.dll" version 201 successfully loaded

        shared lib "dw_mdm.dll" version 201 successfully loaded

        rdisp/softcancel_sequence : -> 0,5,-1

        use internal message server connection to port 3900

        Wed Aug 26 22:09:47 2009

            • WARNING => DpNetCheck: NiAddrToHost(1.0.0.0) took 4 seconds

            ***LOG GZZ=> 1 possible network problems detected - check tracefile and adjust the DNS settings [dpxxtool2.c 5518]

            MtxInit: 30000 0 0

            DpSysAdmExtInit: ABAP is active

            DpSysAdmExtInit: VMC (JAVA VM in WP) is not active

            DpIPCInit2: start server >slmqlsbi1_BIP_00 <

            DpShMCreate: sizeof(wp_adm) 29792 (1752)

            DpShMCreate: sizeof(tm_adm) 5912704 (29416)

            DpShMCreate: sizeof(wp_ca_adm) 24064 (80)

            DpShMCreate: sizeof(appc_ca_adm) 8000 (80)

            DpCommTableSize: max/headSize/ftSize/tableSize=500/16/552064/552080

            DpShMCreate: sizeof(comm_adm) 552080 (1088)

            DpSlockTableSize: max/headSize/ftSize/fiSize/tableSize=0/0/0/0/0

            DpShMCreate: sizeof(slock_adm) 0 (104)

            DpFileTableSize: max/headSize/ftSize/tableSize=0/0/0/0

            DpShMCreate: sizeof(file_adm) 0 (72)

            DpShMCreate: sizeof(vmc_adm) 0 (1864)

            DpShMCreate: sizeof(wall_adm) (41664/36752/64/192)

            DpShMCreate: sizeof(gw_adm) 48

            DpShMCreate: SHM_DP_ADM_KEY (addr: 000000000F210050, size: 6614144)

            DpShMCreate: allocated sys_adm at 000000000F210050

            DpShMCreate: allocated wp_adm at 000000000F212270

            DpShMCreate: allocated tm_adm_list at 000000000F2196D0

            DpShMCreate: allocated tm_adm at 000000000F219730

            DpShMCreate: allocated wp_ca_adm at 000000000F7BCFB0

            DpShMCreate: allocated appc_ca_adm at 000000000F7C2DB0

            DpShMCreate: allocated comm_adm at 000000000F7C4CF0

            DpShMCreate: system runs without slock table

            DpShMCreate: system runs without file table

            DpShMCreate: allocated vmc_adm_list at 000000000F84B980

            DpShMCreate: allocated gw_adm at 000000000F84BA00

            DpShMCreate: system runs without vmc_adm

            DpShMCreate: allocated ca_info at 000000000F84BA30

            DpShMCreate: allocated wall_adm at 000000000F84BA40

            MBUF state OFF

            DpCommInitTable: init table for 500 entries

            rdisp/queue_size_check_value : -> off

            ThTaskStatus: rdisp/reset_online_during_debug 0

            EmInit: MmSetImplementation( 2 ).

            MM global diagnostic options set: 0

            <ES> client 0 initializing ....

            <ES> InitFreeList

            <ES> block size is 4096 kByte.

            <ES> Info: em/initial_size_MB( 5887MB) not multiple of em/blocksize_KB( 4096KB)

            <ES> Info: em/initial_size_MB rounded up to 5888MB

            Wed Aug 26 22:09:48 2009

            Using implementation view

            <EsNT> Using memory model view.

            <EsNT> Memory Reset disabled as NT default

            <ES> 1471 blocks reserved for free list.

            ES initialized.

            mm.dump: set maximum dump mem to 96 MB

            J2EE server info

            start = TRUE

            state = STARTED

            pid = 66548

            argv[0] = I:\usr\sap\BIP\DVEBMGS00\exe\jcontrol.EXE

            argv[1] = I:\usr\sap\BIP\DVEBMGS00\exe\jcontrol.EXE

            argv[2] = pf=I:\usr\sap\BIP\SYS\profile\BIP_DVEBMGS00_slmqlsbi1

            argv[3] = -DSAPSTART=1

            argv[4] = -DCONNECT_PORT=65000

            argv[5] = -DSAPSYSTEM=00

            argv[6] = -DSAPSYSTEMNAME=BIP

            argv[7] = -DSAPMYNAME=slmqlsbi1_BIP_00

            argv[8] = -DSAPPROFILE=I:\usr\sap\BIP\SYS\profile\BIP_DVEBMGS00_slmqlsbi1

            argv[9] = -DFRFC_FALLBACK=ON

            argv[10] = -DFRFC_FALLBACK_HOST=localhost

            start_lazy = 0

            start_control = SAP J2EE startup framework

            DpJ2eeStart: j2ee state = STARTED

            rdisp/http_min_wait_dia_wp : 1 -> 1

            ***LOG CPS=> DpLoopInit, ICU ( 3.0 3.0 4.0.1) [dpxxdisp.c 1694]

            ***LOG Q0K=> DpMsAttach, mscon ( slmqlsbi1) [dpxxdisp.c 12527]

            DpStartStopMsg: send start message (myname is >slmqlsbi1_BIP_00 <)

            DpStartStopMsg: start msg sent

            Wed Aug 26 22:09:49 2009

            CCMS: AlInitGlobals : alert/use_sema_lock = TRUE.

            CCMS: Initalizing shared memory of size 60000000 for monitoring segment.

            Wed Aug 26 22:09:50 2009

            CCMS: Checking Downtime Configuration of Monitoring Segment.

            CCMS: start to initalize 3.X shared alert area (first segment).

            DpJ2eeLogin: j2ee state = CONNECTED

            DpMsgAdmin: Set release to 7000, patchlevel 0

            MBUF state PREPARED

            MBUF component UP

            DpMBufHwIdSet: set Hardware-ID

            ***LOG Q1C=> DpMBufHwIdSet [dpxxmbuf.c 1050]

            DpMsgAdmin: Set patchno for this platform to 201

            Release check o.K.

            Wed Aug 26 22:10:07 2009

            MBUF state ACTIVE

            DpModState: change server state from STARTING to ACTIVE

            Wed Aug 26 22:11:03 2009

            J2EE server info

            start = TRUE

            state = ACTIVE

            pid = 66548

            http = 50000

            https = 50001

            load balance = 1

            start_lazy = 0

            start_control = SAP J2EE startup framework

            Add comment
            10|10000 characters needed characters exceeded

            • Hi Anjali Sharma2,

              The problem was solved. The problem was verified in content of old kernel... particulary with file sapevent.dll which didn't allow to be substituted by the new one! I don´t understand why but that was the problem...

              But thank you in anyway Anjali Sharma2 for trying to help me! 😉

              Best Regards,

              João Dimas