Skip to Content
author's profile photo Former Member
Former Member

Error in COPA Delta

Hi,

While I was trying to change the Timestamp of a COPA Delta load to a previous load in transaction KEB5, I got the following Error Message:

"Master Record for Datasource 1_CO_PA800IDEA_AC is defined for generic delta Read

Timestamp could not be set"

What might be the possible reason for such a Error Message. Could anybody help me in this regard ???

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 26, 2009 at 11:49 AM

    When did you create your COPA datasource? You know, for DataSources that were created in a PlugIn release higher than PI2003.1, there is no option to explicitly specify the time stamp for the delta extraction. You can set, by transaction KEB5, the time stamp only for older DataSources.

    See note 502380, 814311.

    what's your scenario?

    f.galli

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Please get me the solution for this particular scenario.

      Let us suppose that i created the datasource some 1 year back and running the deltas successfully since then.

      Let us number the requests from 1,2,3... and so on since 1st jan 2009. And let us suppose each request loads

      some 1000 records everyday from ECC to BI.

      Now on 10th august some change was made to ECC( such as change in the User Exit ) that caused the mismatch in number of data records ( loading only 950 records ) since the change was made on 10th August. But I identified the problem on 17th august with request number 160. Let us say those request numbers are 153(10th),154(11th),155(12th),156(13th),157(14th),158(15th),159(16th),160(17th). I fixed the program in ECC on 17th and further the requests from request number 160(17th) are fetching the correct number of data records. Now I need to delete the data in BI for request numbers 153 till 159 since they are not reconciling the data of ECC with BI. Now we reload the deltas for such requests from ECC to BI. So how do I reload the deltas now in this scenario since ECC system keeps track of the last delta ie.. on 17th august(Req no 160). But how do I Load the deltas from req number 153 to 159 from ECC to BI.

      One proposed solution to this problem was setting the timestamp of COPA to 10th august. But it is not advised to set the timestamp for COPA datasources using the KEB5 transaction in a production system.

      Now in this scenario how do I load the request numbers 153 to 159 from ECC to Bi to fetch the correct data records for that period. Please propose a solution for this problem ASAP. U can also call me back whenever u need.

      Thanks in advance

  • author's profile photo Former Member
    Former Member
    Posted on Aug 26, 2009 at 05:43 PM

    Not received sufficient information for resolving the scenario

    Add a comment
    10|10000 characters needed characters exceeded

    • How you choose to do this can be summed up by the question: Does the target for this data have cumulative or non-cumulative Key Figures?

      If you are doing an overwrite to the Key Figures, you could just execute a Full Repair InfoPackage that extracts the data for the days that you found inconsistencies instead of attempting to change the timestamp in KEB5 on the source ECC environment.

      However, if you're target has cumulative Key Figures you're left with very few options (a couple of them are time-consuming):

      1) Changing the timestamp in KEB5, if your plug-in is PI 2003.1 or older. Newer versions of the plug-in do not allow the changing of the timestamp as was pointed out by Ferruccio earlier.

      2) Deleting the keys in the target InfoProvider for those records that you extract in a Full Repair extract.

      3) Delete all data in BW for COPA and start from the beginning. This may be your best bet for cleaning up the issues in this scenario.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.