Skip to Content
0
Former Member
Aug 25, 2009 at 11:52 AM

Searching Marketing Attribute Sets with Authorization Object

20 Views

Hi

Using PFCG I am trying to restrict users to seeing only certain marketing attribute sets. I used the authorization object C_KLAH_BKP and entered the 3 char key e.g. AME which the attribute sets are set to in the authorisation field in transaction CRMD_PROF_TEMPL.

In the UI > Marketing > Search Marketing Attributes I click on the Search button without entering any criteria. Nothing is displayed in the search result. I know I have attribute sets set up for AME so this appears wrong.

If I click on the Search button having entering the first few characters of a marketing attribute set ID that I know have AME in the auth field the search result displays the attribute sets. This would be correct.

If I click on the Search button having entered the first few characters of a marketing attribute set I know exists but does not use AME in the auth field the search result does not display anything. This would be correct.

If I take out the authorization object altogether and do a search without entering any criteria, the search result shows all the attribute sets. This would be correct.

What is going wrong is where I have entered an authorization object and executed an empty search. I would expect to see only the marketing attribute sets allowed. This does not happen. No results are returned.

Has anyone got this to work using an authorization object? I feel this is a bug but would like to make sure before I raise an OSS message.

Cheers

Declan