Skip to Content
1
Sep 22, 2018 at 04:37 PM

Argh!!!!!! Why cant i run my webapp created in MTA along with XSOdata inside the nodejs service

175 Views Last edit Sep 23, 2018 at 10:49 AM 3 rev

Hello Colleague,

I have been struggling so hard , for 2 months here already. i could manage to run the webapp with Neo destination. I want to run the entire module in application specific URI. However i cannot call the web module in the nodejs url/(xsodata,xsjs).

ill share my MTA Yaml file looks like this with Destinations.

if you see i defined my destinations . and the name is Core_backend

Now in xsapp.json i mentioned the route for my destination.

and finally i have made changes with my controller

So you can see how i pointed the destination .

when i run two issues happens.

Issue no 1: when i run the webapp it runs on webide environment and not on my application service in cloud foundry .

Issue 2 :Can read the destination. i dont want neo destinations to be used ,i want to access the destination i created from MTA.yaml file.

Final note:- this app i am building at my free time so it can be available to HR consulting people to optimize and accrue the best candidates by matching thier demands irrespective of location from different locations.

Please find the GIT URL to extract. (to follow my work and also contribute)

https://github.com/ashlingabriel/CF_HRM_APP.git

Attachments

pic1.png (60.6 kB)
pic2.png (52.5 kB)
pic3.png (54.6 kB)
pic4.png (89.1 kB)