Skip to Content
avatar image
Former Member

How do I increase the database connections for my AEX?

Hi every one

Please help me. I need change the number of connection to data base of AEX, I found this parameter in the NWA, but how I can edit. Thanks in advance.


asdf.png (26.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 19, 2016 at 11:24 PM

    Hello Jose,

    Maximum connections parameterization of the JDBC System DataSource can be changed using ConfigTool: there, navigate to 'services' > 'dbpool', corresponding parameter name is 'sysDB.maximumConnections'. As a reference, you may check SAP Note 2310320 - even though it describes setting of the other parameter of the JDBC System DataSource, the approach remains the same as for the one you are looking at. Please note that since this parameter is not online modifiable, in order for changes to take effect, system restart is required.

    I would also encourage you to take caution when changing this parameter value: its generally recommended value for PI/PO systems, is '100' (refer to SAP Note 1375656), and any deviation from this value shall be well considered and tested, since major decrease / increase of concurrent connections to PI/PO database may negatively impact performance / stability.



    Add comment
    10|10000 characters needed characters exceeded

  • Nov 22, 2016 at 11:17 AM

    Hello Jose

    in case what you want to achieve is to have more threads connecting to external DBs, check SAP note 831162, point 28 the number of connections to external databases will be dramatically increased if you play with those parameters and you increase the number of threads available in your PI enviroment available per JDBC adapter. The adapter specific queues in the messaging system have to be configured in the NWA using service “XPI Service: AF Core

    If you setup 20 threads and you have concurrent connections as this note states, you can see how this affects.


    Add comment
    10|10000 characters needed characters exceeded