Skip to Content
-1

SAP HANA XSA SPS 3: After deploying, the index.html could not be found

Hi Experts,

we do have the issue, that after we deployed a new app in our productive system, we are not able to reach the app, because of a missing index.html. But the index is in the mtar file and the app is running.

The deployment finished without any issues. In the dev system is the app working fine. I did the deployment more times, also on two different spaces and everything of the deployment process looked fine.

I could only find this inside of the log of the deployment:

ERROR#/Handler########xxxxxxxx######jmap70iq#PLAIN##GET request to /index.html completed with status 404 - error during fs.realpath: ENOENT: no such file or directory

Any ideas?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Sep 23, 2018 at 11:17 AM

    Could solve this issue.

    (The index.html was in the webapp folder, what this issue caused.)

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.