Skip to Content
avatar image
Former Member

Multi-lingual attribute Alias

Hi, I am having trouble updating attribute aliases in different lang. We use English, Spanish and Portuguese language in our repository.

When using the import manager logged in with the English language selected I can only map to the English Alias to add or update attribute.

When login in with the Spanish language I can map to the Spanish Alias, however my mapping actions are now Updated (All mapped fields) and Replace, Update (Null Fields Only) is greyed out.

When performing the Update it overrides my English Aliases with the Spanish.

Same happens when attempting to update Portuguese.

We have MDM 7.1 package 11.

Any help will be appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Aug 25, 2009 at 08:53 AM

    Hi Chris,

    When you open MDM Data Manager in Taxonomy mode. On Clicking Attribute Language Detail tab you will see you have three things multi-lingual Name, Alias and Definition. So if you manually write Alias for other two languages using Data Manager

    Spanish and Portuguese it will work and in this way you can have attribute Alias in different languages.

    Using Import Manager you are facing

    When performing the Update it overrides my English Aliases with the Spanish.

    Same happens when attempting to update Portuguese.

    when you set Configuration Options Expand Multi-lingual text fields = As multiple fields you will see in your target table Name, Coupled name and Definition as multi-valued fields only not Alias. thats why you are not getting Alias in all different languages.

    As per my understanding, i think may be it is some sort of bug into MDM Import Manager. If your Alias field also come as Multi-lingual then may be you would able to import data into all different languages and it will not override.

    So may be you need to manually maintain data for Alias in all different languages using MDM Data Manager Taxonomy mode -> Attribute Language Detail tab.

    Hope it will help you,

    Thanks & Regards,

    Mandeep Saini

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi, thanks for the reply.

      I have check configuration options and it is correct.

      Doing this manually is not going to work, we have about 5 000 attributes and counting.

      Regards