Skip to Content
author's profile photo Former Member
Former Member

Use of EVPRO to get Parenth1 value

Dear All,

I am trying to use EVPRO(evapp(),"Member","Partenth1") to get the Parent of any member. But it is returning #NODATA

Why is it failing? When I am trying to get "ID" or any other property value using EVPRO, it is sucessful. But for ParentH1 value, it returns #NODATA....

What's the solution...Or Is there any other method to get parent of any member.

Regards,

Ankush

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2009 at 06:33 PM

    Make sure the column where you are entering the EVPRO has the format set to General. Click on Format and then Format-General.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ankush,

      I'm not sure if it's possible to call the PARENTH1 property using EVPRO, but if you really need to show the parent of a member, why not try to create another property and copy the PARENTH1 value to that property and then you can call that property you made to get the parent value of a dimension member.

      Hope this helps,

      MVS

  • author's profile photo Former Member
    Former Member
    Posted on Aug 24, 2009 at 01:10 PM

    The EVPRO on the parent works on 7M sp3 and higher, and 5.1 sp8 and higher. Any earlier release and it doesn't work.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.