Skip to Content

TST_ERROR when installing Diagnostic Agent

Hello All,

I am installing Solution Manager 7.2. As part of that, I am bringing all of the Diagnostic Agents up-to-current. I have a NW7.4 new install that has been sitting a while until I got Solution Manager running and it has a Diagnostics agent that was down 1 level. I removed the old diagnostics agent.

When I attempt to install the newer version using SWPM, it ends with the following error:

Execution of the command "/bin/csh -c "source /home/daaadm/.cshrc; env" finished with status TST_ERROR.

I am running SWPM as user root, which is also in group sapinst. I attempted the command as user root in /home/daaadm, and it works correctly. I tried it as user daaadm, and it works correctly. I run it from root doing su to user daaadm "su - daaadm -c "command above" and it also works.

I looked at a few notes, including 1875902, and I can't see where there is an issue with the .dbenv_hostname.csh or .sapenv_hostname.csh profiles. I compared to systems where it worked, and the profiles look identical. Environments look correct. Directory ownership and permissions look correct. Any ideas here?

I did see someone suggesting that if the HOST agent was reinstalled first it would fix problems with Diagnostics agent. When I attempted to reinstall the host agent, I received the same TST_ERROR.

Thanks.

Danny Hearn

Dematic Corp

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 17, 2016 at 03:35 PM

    And I've already found the answer. I continued searching and I found out that you need to switch user root to csh before starting sapinst.

    Found the answer in this ticket:

    1 : Login as root

    2 : csh

    3 : setenv SHELL /bin/csh

    4 : continue with sapinst

    https://archive.sap.com/discussions/message/13555908#13555908

    Add comment
    10|10000 characters needed characters exceeded