Skip to Content
avatar image
Former Member

Hybrid application toolkit app build error "Target command should not have two arguments"

Hi All,

I am trying to deploy a fiori kapsel application using HAT and making use of only the logon plugin but unable to do so and getting an error "Target command should not have two arguments" Invalid argument.

Have attached scn for better understanding.

The error seems with HAT please help resolve the same.

Many thanks

Archit Wahi

kapsel-error.png (112.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 18, 2016 at 01:07 PM

    I would recommend updating your HAT version to the newest. The issue could also be related to the underscore in your project name. Some versions of cordova had problems with this.

    Regards,

    Jamie

    SAP - Technology RIG

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jamie,

      Thanks for your reply. I tries without the underscore but still getting a similar error. scn attached.

      My webide is a jan 16 release. Please suggest a suitable HAT version.

      Best Regards

      Archit Wahi

      kapsel-error2.png (48.5 kB)
  • Nov 22, 2016 at 05:25 PM

    I believe you will have to move to a HCP version of Web IDE to use HAT. According to

    https://help.hana.ondemand.com/webide/frameset.htm?5b8bca3147ee4dfd99be8aaf6bd4f421.html

    optional plugins are not supported. You can find information regarding HAT at

    https://help.hana.ondemand.com/webide_hat/frameset.htm

    Regards,

    Jamie

    SAP - Technology RIG

    Add comment
    10|10000 characters needed characters exceeded