Skip to Content
avatar image
Former Member

Import Manager "forgeting" previous mapped values // manual edition maps

that's my problem,

we are loading few information(columns) on the customer master (arround half million entries) into a repository, and every new file fails due to unmapped values (each file from XI with thousand entries)

the thing, I go the the import manager, open the port Exception, map the missing values SAVE THE MAP, and the manually import,

next file, it fails again, same problem, unmapped values, I do the same process, (being sur eI save the map)

next file, fails once more, same problem, but not with the same values that I map the last time, but with values that I did map a earlier time.

Something like, each time I save the mapping, rewrite the maps, instead of addign them

is that something I could do ??

otherwise, is any way I could edit manually the table of conversion values ?? (so I could add all values at once)

thank in advance,

note :: mdm 5.5

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 19, 2009 at 11:43 AM

    Hi Pedro,

    Check if the fields failing to get mapped are clone or compound fields.

    These fields cannot be saved in map, and hence need manual mapping.

    Also, when you are correcting the map and saving it again, go for save update rather than the save option.

    Hope it helps.

    Thanks,

    Minaz

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Save update ...

      whene the hell (just letting my frustration going out) sap thought that this terms are good terms for such a two diferent functions ?? (replace mapping and extend mapping).

      And what is even worst, who tought to give the replace action an icon and not to the extend acction ??

      Of course, look the documentation is completele pointles

  • avatar image
    Former Member
    Aug 19, 2009 at 11:55 AM

    Hi Pedro

    there are two solutions for this:

    1. Enable remote key mapping for all the Lookup tables and the automapping of values will happen.

    2. for the first time prepare an import map with a dummy source file which contains all possible combinations of values allowed for different fields. Save this map. then for importing the regular load files which will always have a subset of the values(from the Full source file) use this map.

    bets regards

    Ravi

    Add comment
    10|10000 characters needed characters exceeded