Skip to Content
0

Enterprise portal issue with script in detailed navigation

Nov 17, 2016 at 12:32 PM

73

avatar image
Former Member
Hi All! We have an issue in our enterprise portal (7.40) We are playing with IE compatibility settings. (Browser document mode in framework page is set to IE=Edge now). since then we are facing issues with unfolding the menu structure in the detailed navigation pane. I will try to attach screenshots to illustrate the issue. In chrome everything works fine. Can you help me in the right direction please? We also seem to have some script scanner installed on our corporate systems. But I asked our security department to exclude the portal url from the script scanner and still facing the same issue. 
Below reporting new level in the structure should be shown, but instead it is showing the dots above. 

The IE script inspector is throwing an error: 

function onload(event)
{
if( (window.frames[this.name]!= null) && (window.frames[this.name]!= undefined) ) loadAndHandle('/irj/servlet/prt/portal/prtroot/pcd!3aportal_content!2fevery_user!2fgeneral!2fdefaultDesktop!2fframeworkPages!2fcom.sap.portal.frameworkpage!2fcom.sap.portal.innerpage!2fcom.sap.portal.detailedNavigationTree?uniqueSequence=1',window.frames[this.name].xmlStr)
}

Do you have any suggestion in which area I should look for the solution:
- portal is running in chrome
- issue is there while running in IE=Edge apparently
- before compatibility was set to IE=EmulateIE7, then all was working fine
- what we try using is the default framework delivered by SAP
 
1.png (3.7 kB)
2.png (22.3 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Jinnyre Malazarte
Nov 17, 2016 at 01:38 PM
0

Hi Bart,

Thanks for using SAP Answers.

A helpful blog regarding the browser document mode:

https://blogs.sap.com/2014/09/03/ie-and-portal-standardsquirks-mode-evolution-or-love-hate-relationships/

Have you tested the issue without Compatibility Mode set and the Browser Document Mode set to "IE=5, IE=EmulateIE7" without the quotes?

Best Regards,
Jinnyre Malazarte

Share
10 |10000 characters needed characters left characters exceeded