Skip to Content
author's profile photo Former Member
Former Member

How to make stock type as blocked stock by default in pourchase order

How to make stock type as blocked stock by default in pourchase order, please give me solution immediately.

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2009 at 05:40 AM

    In the PO , item overview i dont remember the exact tab i think it is qty or material tab in that change the storage type to block.

    Hope this helps u.

    Regards,

    AM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2009 at 05:42 AM

    Hi,

    Manualy you can set at Item level, Delivery tab --> stock type else, try with any of the following BAdi

    BAdI: Enhance Processing of Enjoy Purchase Order

    BAdI: Customer's Own Screens in Enjoy Purchase Order

    BAdI for BAPI_PO_CREATE1 and BAPI_PO_CHANGE - BUS2012

    Regards,

    Vikas

    Edited by: Vikas Mayekar on Aug 14, 2009 7:42 AM

    Add a comment
    10|10000 characters needed characters exceeded

    • HI,

      Here is a simple way.When u create a PO enter all dat then in item detail,select the block stk & goto the system at top.here select

      user profile & click on set data & save the PO.Then every time when u create the PO the blocked stock will be defaulted.

      NOTE-U should not log out of SAP.If u log out then u have to set it again.

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2009 at 05:59 AM

    In T code ME22n, please change the Stock type to "block stock" in Item details -> Delivery Tab.

    Regards

    Bhavesh Mistry

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2009 at 06:01 AM

    Hi

    Why do you want to default the stock type at PO level.

    Better set the default settings in MIGO>Settings>Default values> make it to Blocked stock for the Mvt type.

    Hope it helps.

    Thanks /karthik

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.