Skip to Content
author's profile photo Former Member
Former Member

ALV Output in Background is not coming fully

Hi Frnds,

When i executed the Z report, ALV grid output is coming with all columns as i specified in the report.

But, When I executed the report in the background ALV output is coming as the List with only some columns.

My problem is... Not able to all the columns in the output of spool.

what shall i do to get the all the columns in spool?

Regards,

Sunny

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • Posted on Aug 13, 2009 at 06:32 AM

    Hi,

    Check ur printer settings u can change it, But i dont think u can display more than 255

    Regards,

    Prashant

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 13, 2009 at 11:06 PM

    In background by default it will pick the ALV list properties instead of grid properties. Check the list properties for GRID display and maintain the same for list properties (column properties) also. It should work.

    Regards,

    Amal

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 14, 2009 at 12:06 AM

    Please ensure COL_POS in the field catalog filled properly.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2009 at 06:59 AM

    hi friend .

    check this .

    regards

    surender.s

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2009 at 07:01 AM

    there is a button in sp01 output screen called extended view. just after the display button.

    use that one.

    else

    change printer settings

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2009 at 07:09 AM

    Hi Sunny,

    This problem is because in back groud while creating spool, system picks up only 255 caracters form left. that is why it is not comming fully in background mode.

    There is not spool setting required for this issue.

    solution:

    1. you can remode unwanted or less important fields form the ALV output so that it can be fit in 255 char reange

    2. Create a hierarchical ALV which can be fitted in that range

    Regards,

    Raj Gupta

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 14, 2009 at 07:20 AM

    HI,

    Please check the below link

    spool-list-output-display--255-char-when-the-rpt-i

    Regards,

    Nagaraj

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.