Skip to Content
0

getworkorderssteplet - time limit exceeded agentry

Nov 17, 2016 at 10:04 AM

147

avatar image
Former Member

Hi Experts,

I am using SMP 3.0 SP11, when i am transmitting sap work manager, it giving me "error getworkorderssteplet - time limit exceeded agentry".

So please suggest what is the max time we need to configure in smp server cockpit. its happening because there are lots of job assigned to user.

Regards

Mohit Tyagi

10 |10000 characters needed characters left characters exceeded

Mohit,

Hi. Question: Before the point of failure, did you notice what was the time during your transmit from T0 to Tf where T0 is initial time and Tf is the time of failure? What is the duration before you saw the error?

From the point of failure:

If it is exactly 5 minutes, you may be experiencing a software hard code time limit of the default 5 minutes.

Your error is tied to the getWorkorderssteplet so this could be tied to the Java section (JVM). If you look at the cockpit, there is an area that it may be listed as milliseconds just look up all your entry to make sure you did not state something to be 300 but it is in milliseconds.

Additional knowledge that we know that we give customers is that the configPanel has an ability to reduce number of volume of workorders or data through filtering. Based on the other 2 comments, here you may try to see if you can just simply tweak the data/time in the configPanel or just not allow the user to download more than 125 objects (Workorder). Golden rule of thumb is about 125 objects for a pocketPC type of device (it may be more for higher performance devices or faster devices). The transmit time is relative to how fast your mobile device processes the data. A Windows CE device may be slower compared to its Android/iOS counterparts and this could influence your transmit.

Best Regards,

Mark Pe
SAP Platinum Support Engineer

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Feb 02, 2017 at 01:40 AM
0

What is the volume of work orders? You could try to add more filters on order types.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you so much Alok.

We increased JCO time out settings in SAP and it's fine now.

-Sudhir.

2
avatar image
Former Member
Apr 05, 2017 at 10:11 AM
0

Hi Mohit,

Try putting 720 in the config panel instead of cockpit.

Regards,

Shashank

Share
10 |10000 characters needed characters left characters exceeded