Skip to Content

Displaying Blank Page from crystal report 13 with Visual Studio 2010

Hi Friends,

I have recently updated the crystal report version to 13 and visual studio version to 2010 with Framework 4.0 in ASP.NET C# in windows server 2012.

Some times when we print the Invoice report it works fine but after some time it throws the below error. We have to manually re-start the server to print the reports again

Getting error as follow:

Error Message:

'Invalid printer specified'. temp_ea25c3c7-c1d6-4114-b5ee-fa194f09551c {3BF991E6-89A4-476C-9DAE-BEBB6281348E}.rpt Source: Analysis Server Trace: at CrystalDecisions.ReportAppServer.Controllers.PrintOutputControllerClass.ModifyPrinterName(String newVal) at CrystalDecisions.CrystalReports.Engine.PrintOptions.set_PrinterName(String value)

and displaying Invoice report as Blank page but after restarting the server its working fine for few hours and again return back to Blank Page.

This has been working fine in dev side, but in server side we getting error as below.

In server side also Windows server 2003, is working fine.

We have checked with following scenarios.

1. Printer name is same as configured printer.

2. Crystal ActiveX Report Print Control 13.x is installed

Please kindly help to fix this issue, if this been permission related issue, Please explain clearly.

Thanks and regards

Kalaivanan

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Sep 20, 2018 at 12:56 AM

    In Windows Server 2003, you didn't have to install the printer drivers to the server in order to be able to print from it. However, in 2012, the printer you're trying to print to from your code must be one of the printers listed in the printers installed for the server.

    Also, Windows Server 2012 is finicky about security, so it may have issues with the ActiveX printer.

    A last thing to look at would be your code. Which version of the SDK are you using (go to Control Panel >> Programs and Features to determine which service pack is installed). Does the version on the developer's workstation match the version on the server? Then MUST match!

    -Dell

    Add comment
    10|10000 characters needed characters exceeded