Skip to Content
avatar image
Former Member

Navigation button problem in Table

Hi Experts,

I am embedding a table in the view.

The row navigation are displayed while creating

But when i run the application, the row navigation buttons are not being displayed,

Can you explain why this is happening? Is there any settings to be changed in table?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Aug 01, 2009 at 11:17 AM

    Hi Mohammed,

    Did you try change the application's parameter setting to PAGINATOR? That might be 1 problem or else I guess that you must be working on the Netweaver 7.01 version. SAP has now transitioned the table to make use of only the scrollbars i.e, in other words you would not be able to see the standard row navigator option anymore. You can try go through this [thread |WDTABLENAVIGATION;wherein Thomas Jung explains in detail the reasons behind the same.

    Regards,

    Uday

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Mohammed,

      Well there isn't any way by which you can still use your PAGINATOR coz if you had seen the other [thread |WDTABLENAVIGATION;which I had passed on to you Thomas had clearly said:

      You are on NetWeaver 7.01. Now the Scrollbar is the default value and in Lightspeed rendering only the
       Scrollbar is used. The Paginator setting is ignored.
      
      There is a note to this effect in the online help for the table UI element:
      When the WDLIGHTSPEED parameter is activated in accessibility mode, paginators are not used any more.
      The corresponding application parameters for the paginator and accessibility mode are ignored.

      Also Markus had tried setting off the WDLIGHTSPEED parameter so that he could try realize his PAGINATOR functionality. But as how Thomas has said:

      1) Even though you switch off the WDLIGHTSPEED parameter

      2) Even thoughy ou still have the PAGINATOR parameter being available in the parameters tab of your application

      Its not possible anymore to have this functionality available inside your WDA components.

      Regards,

      Uday