Skip to Content
avatar image
Former Member

Error in accesing the URL for Sender SOAP Adapter

Hi Experts,

I am wrkiing on SOAP-XI-Proxy Scenario. i have completed IR, ID and WSDL generation process.

While Generating the WSDL File I used following URL. (No Party in my case)

http://domain name:Port no/XISOAPAdapter/MessageServlet?channel=:SYS_BS1:CC_SOAPSender_Test1

When i run this same URL on the browser, it asks me the username/password.

After entering the username/password i am gettnig the Following Error.

Message Servlet is in Status OK

Status information:

Servlet com.sap.aii.adapter.soap.web.MessageServlet (Version $Id: //tc/xpi.adapters/NW07_06_REL/src/_soap_application_web_module/webm/api/com/sap/aii/adapter/soap/web/MessageServlet.java#4 $) bound to /MessageServlet

Classname ModuleProcessor: null

Lookupname for localModuleProcessorLookupName: localejbs/ModuleProcessorBean

Lookupname for remoteModuleProcessorLookupName: null

ModuleProcessorClass not instantiated

ModuleProcessorLocal is Instance of $Proxy123_10000

ModuleProcessorRemote not instantiated

I have confimed that SOAP sender channel is active and configuration object is also tested in ID.

I have searched the similar threads but not found proper solution.

Please suggest.

Regards

Jagesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Aug 04, 2009 at 06:00 AM

    As I said earlier "Don't worry about the URL" 😊

    Nice to know that your scenario is working.

    In your case "Message Servlet is in Status OK" should mean that everything is fine. Just to confirm this, I told you to run end to end scenario.

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 01, 2009 at 10:00 AM

    Have you tried to actually send data to PI using this URL and wsdl? I think it should work.

    Make sure that when it prompts for username and password use PIAPPLUSER or any user with roles similar to this user.

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      The URL that you are using means that you are not hitting the AE....but are directly hitting your message to IE....the use of this URL is mentioned in one of the blog by Stefan: /people/stefan.grube/blog/2006/09/21/using-the-soap-inbound-channel-of-the-integration-engine

      When you test the scenario end-to-end just check if your Sender SOAP CC shows any log!

      Regards,

      Abhishek.