Skip to Content
avatar image
Former Member

No service for system SAP***, client 001 in Integration Directory

Hi,

We are doing a File to IDOC scenario.

The file is picked up and the idoc is getting generated in XI but this idoc is failing at XI outbound with the following SM58 error:

No service for system SAPABC, client 001 in Integration Directory

where ABC is my XI system ID.

I have searched in sdn and tried all the possible solutions given in the previous blogs with same subject but not able to resolve this error.

Any help will be greatly appreciated.

thanks in advance

Jagruthi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jul 30, 2009 at 03:47 PM

    Check your receiver business system -> Service -> Adapter Specific Identifier, if the entries are appropriate.

    You may also try header mapping in the receiver agreement. There you need to specify the name of XI business system ABC in the name of sender service. Then try your scenario again.

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Prateek,

      the adapter specific identifier for both sender and reciever system is maintained correctly. The value for this identifier (Logical system name) is taken from BD54 txcode.

      we have tried with Header mapping but still getting the same error.

      regards

      Jagruthi

  • avatar image
    Former Member
    Jul 30, 2009 at 03:48 PM

    Hey

    Could you please check SLD and make sure that you have maintained business system for ABC system.

    Thanks

    Aamir

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Aamir,

      I have maintained Business sytem in SLD for both XI and R/3. SLD configuration is done completely.

  • Jul 30, 2009 at 04:11 PM

    Hi Rao,

    please check given link may be useful for you

    /people/michal.krawczyk2/blog/2005/03/29/xi-error--unable-to-convert-the-sender-service-to-an-ale-logical-system

    no-service-for-system-in-integration-directory

    Regards,

    amit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 05, 2009 at 09:44 AM

    Hi,

    we were geeting this error coz the reviever R/3 system was configured as integration server in sxmb_adm transaction by mistake.

    We have changed that to application system and are able to get the idocs in R/3 after that.

    thanks all

    jagruthi

    Add comment
    10|10000 characters needed characters exceeded