Skip to Content
avatar image
Former Member

Doesn't have XI adapter on Adapter Engine Monitor

Hi Experts,

I am doing File2File scenario with J2SE->XI->J2SE direction. So that I created a communication channel(CC) with XI type and Receiver role. It have no error, the status of message is always "Waiting". The sender and receiver file adapter on J2SE also has no error.

I checked adapters on my XI server(in XIRWB), I don't see XI adapter in it. It has adapters like: BC,CIDX,FILE,JDBC... I dont' know why.

Have you got any ideas, please help me. Thanks very much.

thach vn

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Jul 31, 2009 at 09:34 AM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      The response you see comes from the J2SE listener - the http command your browser sends is not implemented.

      It indicates however that the http service is running on that port and ready to receive data from XI.

      What you need to make sure is that your J2SE webUI is listening on another port than your adapters. If that is the case, log in to your J2SE webUI, check if your receiving adapter is Started (Initialized won't suffice) and check the logs if anything shows up.

      Last item to check if also that fails:

      On your XI box, issue the following command:

      telnet host 1000

      and see if you get a reply or a "connection refused".

      Regards,

      Stefan

  • avatar image
    Former Member
    Jul 30, 2009 at 08:54 AM

    Hi,

    Check with your basis team, i think somewhere option is mising. That is the reason XI adapter not getting in list. They will sort out easily. Development level we don't have any option.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 30, 2009 at 08:58 AM

    Hi,

    Is your message reaching XI? That means is there entry in SXMB_MONI? If yes then there is no issue with the sender channel (else you can see the error in J2SE sender itself).

    Now are you getting this error in Receiver side? If so then the message in moni will be going into automatic restart/error state. Is this the case?

    Check whether the certificates (in strust transaction of XI) and credentials (in Receiver XI channel) are correctly used.

    Regards

    Suraj

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      IT seems you are not able to send message to receiver j2se adapter. There is some connectivity issue between XI and receiver J2SE.

      Check whther the following url gives you some results or not:

      http://10.10.1.25:1000/file/test

      are you able to open the j2se url from XI machine? Recheck the ports and file path a;so the user shoudl not be locked in J2SE side

      Regards

      Suraj

  • Jul 30, 2009 at 09:01 AM

    Hi vn thach ,

    This is the problem with your Java Stack. Ask your BASIS people to restart the java server. They can only solve your issue.

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 30, 2009 at 09:04 AM

    Hope this discussion helps

    XI Adapter not visible in Comm Channel Monitoring ?

    Please check the reply by Vinod

    Regards,

    Manjusha.

    Add comment
    10|10000 characters needed characters exceeded