Skip to Content
avatar image
Former Member

Error upgrading JAVA SP19

Hello,

I am trying to upgrade to JAVA SP19 and I have the next message when continuing to deploy the components (some of them were deployed previously but I had to do a new deployment due to a Task Limit error):

Caught CVersProxyAccessException while saving repository: CVersAccessException: Can not load mandatory table BC_COMPVERS, desc == null

The last part of the log is:

Jul 29, 2009 2:29:15 PM Info: Ending deployment prerequisites. All items are correct.

Jul 29, 2009 2:29:24 PM Warning: Caught CVersProxyAccessException while saving repository: CVersAccessException: Can not load mandatory table BC_COMPVERS, desc == null

Jul 29, 2009 2:29:24 PM Info: -


Ending validation -


It is only a Warning, but the error in the JSPM GUI is : "Error during validation of the dependencies of the selected support package stacks"; it say that "You can validate the compoents again by choosing Retry" but after retrying 4 or 5 times it shows the same error.

I set the Database Name to SAP<SID>DB as I saw in other forum threads without success. This does not work.

Thanks in advance for your help.

Raul.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Jul 29, 2009 at 03:21 PM

    Hi Rahul,

    It looks like processes and sessions parameter value is less at your database. If sometimes when JSPM tries to load the packages and if value of these parameters are less. then it will show this error.

    Check this and change the parameter and restart your database. Then start again.

    Thanks

    Sunny

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      > what are these parameters and what would be these values?

      I ran into the same problem, upgrading from 7.01.4 to 7.01.6. The upgrade worked on standalone sbx and dev systems, but the failed on a clustered QA system.

      The jspm_##.trc file at the point where it failed said:

      Caused by: com.sap.sl.util.cvers.api.CVersAccessException: readSCVersion1: Listener refused the connection with the following error:

      ORA-12519, TNS:no appropriate service handler found

      This guy (http://www.atpeaz.com/index.php/2010/fixing-the-ora-12519-tnsno-appropriate-service-handler-found-error/) says to run the command u201Calter system set processes=150 scope=spfile;u201D in the SQL*Plus, and restart the database. It worked!