Skip to Content
0
Jul 28, 2009 at 04:10 PM

Work Process hung and restarting every 30 seconds

275 Views

Hi All

I'm experiencing something strange and wonder if anyone has any suggestions.

This has happened twice now, once in the ECC 6 and once in the CRM 2007 production system (SQL Server 2005 on a cluster)

In the most recent (happening now) I was running statistics update with Transaction ST04_MSS on several table. On one table the update contunied to run over night and my user id was logged off. But the Workprocess (viewed from sm51) continued to run. Refreshing the screen shows that the Work Process continues to run, but restarts with a new PID every 30 seconds (confirmed via the System Log).

I have tried to Cancel the process with & without core, but it continues. I have even tried to End the process at the OS level with out succes.

I actually have 2 Work processes running like this at the same time now. The dev_disp log shows "DpHdlDeadWp: restart wp (pid=9144) automatically" (of course the pid changes each time) every 30 seconds.

The dev_w3 log shows, for example:

Tue Jul 28 08:41:37 2009

create_con (con_name=r/3)

Loading library DB library 'E:\usr\sap\<sid>\SYS\run\dbmssslib.dll' ...

Library 'E:\usr\sap\<sid>\SYS\run\dbmssslib.dll' loaded

New connection 0 created

sysno 00

sid R3P

systemid 562 (PC with Winidows NT)

relno 7000

patchlevel 0

patchno 181

intno 20050900

make multithreaded, ASC11, 64 bit, optimized

pid 5884

kernel runs with dp version 241(ext=110) (@(#) DPLIB-INT-VERSION-241)

-

-

rdisp/queue_size_check_value : -> off

***ERROR => sapinit: no memory or imporper size for ztta/short_area <= 0(-3) [sapinit.c 1107]

***ERROR => DpMemInit: sapinit 9-3) [dpxxdisp.c 10057]

  • DP_FATAL_ERROR => DpSapEnvInit: DpMemInit

This is the first time this has happened in the ECC 6.0 system and it has only happened once in CRM 2007 system. The fix for the CRM system was to reboot the application. Of course I could do this in the ECC 6 system, but want to figure out why it's happening first.

There are no runtime error DBIF_RSQL_NO_MEMORYshort dumps associated with this.

The ztta/short_area parameter is at the default 1,600,000, which hasn't been touched since upgrade 1 year ago.

The ztta/roll_area parameter is at the maximum value 10,000,000.

Does anyone have any suggestions about what may have caused this or how to cancel it with out rebooting the system?