Skip to Content
avatar image
Former Member

Tcode in S_TCODE Object Error

Hi Experts,

When we are searcing for "Y" Tcode in Menu Tab in "XXX" Role in PFCG,It was not there in menu Tab.

But it was there in S_TCODE Object.S_TCODE Object is maintained one.It was not added manually.

Ex:When I am searcing for SM59 in menu tab,it was not showing any output.But when I given RFC(in find) it displaying all tcodes with RFC name(including SM59 which was not shown when I searched as SM59 ).But it is showing as Service in the place of tcode.

But SM59 was there in S_TCODE Object & it was showing in SUIM & SE16 dump.

Kindly help to solve the above issue.

Regards,

Karthika

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    Jul 27, 2009 at 08:07 AM

    >

    > When we are searcing for "Y" Tcode in Menu Tab in "XXX" Role in PFCG,It was not there in menu Tab.

    > But it was there in S_TCODE Object.S_TCODE Object is maintained one.It was not added manually.

    Hi,

    as the status of your S_TCODE authorization is 'Maintained', it seems to be an 'old' authorization (before the new fucntionality of non-maintainable S_TCODE authorizations have been implemented).

    To solve the issue, simply perform 'read old status and merge with new data'. this will clean up S_TCODE.

    Maybew you will get some surprises of changed authorizations, as the auths seem to be rather old (created before upgrade maybe?).

    b.rgds, Bernhard

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 27, 2009 at 04:51 AM

    if you are adding any t-codes in the menu tab, it will reflect in the S_TCODE auth object.

    Please cross check once again in the Menu tab. it should be there.. Please check with th description of t-codes.

    you may get from that.

    Hope this would help you to resolve your issue.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Thanks for your reply.

      When I checked SM59,it shows "No entry ".But when I checked with "RFC" Word,It is displaying as SM59 description.But under Tcode column it is displaying as 'Service'.It is any settings done when creating the role?.

      Note : the role has nearly 4,000 Tcodes, added through menu tab.

      Regards,

      Karthika

  • avatar image
    Former Member
    Jul 27, 2009 at 06:16 AM

    Hi,

    This is because of that the t-codes being manually added under the object S_TCODE instead of adding in the role menu.

    When you are checking t-code value for the S_TCODE , it will display only roles for which t-code is directly added under the object.

    But when you execute SUIM for a particular transaction, the system checks for the role menu entries.

    if, t-code is not assigned under the menu, it is showing as "No Roles found".

    Let me know,if it helps.

    Regards

    Vikas rana

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      > VikasRana1 wrote:

      > This is because of that the t-codes being manually added under the object S_TCODE instead of adding in the role menu.

      > When you are checking t-code value for the S_TCODE , it will display only roles for which t-code is directly added under the object.

      > But when you execute SUIM for a particular transaction, the system checks for the role menu entries.

      > if, t-code is not assigned under the menu, it is showing as "No Roles found".

      Karthika_SAP has clearly stated that it is not a manually instance of S_TCODE and that it is showing in SUIM.

      Cheers,

      Julius

  • avatar image
    Former Member
    Jul 27, 2009 at 06:18 AM

    It is not easy to understand your question...

    > But it is showing as Service in the place of tcode.

    Services would be a different object, although exposing SM59 as a service seems strange to me. That the name is the same might have been the confusion.

    Check in SU24 for a service (S_SERVICE) which has a "Proposal" flag for SM59 in S_TCODE.

    Cheers,

    Julius

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 05:37 PM

    I've just noticed you mentioned 'Service' below in your original posting?

    "But it is showing as Service in the place of tcode"

    (Haven't worked out how to do a quote on here yet 😊 so I apologise for the crude entry

    Is this on the menu tab that you are seeing the transaction called service please? If so then this would have been added via the authorisation default button instead of the insert transaction button. This can be used to 'hide' a transaction from view of the user (a bit flakey but a final resort sometimes!)

    The transaction will have a hand holding a green card icon next to it instead of the usual three-D box.

    Table AGR_BUFFI holds this info and not AGR_TCODES or AGR_1251 - are you using SUIM or SE16(N) to search?

    Standard SUIM will return the 'SM59' fine but SE16(N) won't.

    See you have solved it but I'm not clear what happened yet so I'll keep digging 0;0

    Edited by: David Berry on Sep 20, 2010 7:49 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi

      See previous replies/searches viz. TCDCOUPLES/SU24 entries.

      This is not related to this answered thread...

      Kind regards

      David

      Edited by: David Berry on Sep 20, 2010 11:41 PM