Skip to Content
avatar image
Former Member

How does the file instance.properties get updated?

The J2EE Processes table of my server named ABC (shown in the Startup Framework) shows:

SDM = running

dispatcher = stopped (Exitcode -11113)

Server0 = stopped (Exitcode -11113)

The file:

T:\usr\sap\ABC\DVEBMGS00\j2ee\cluster\instance.properties

Gets written each time the server starts up and the value

instance.ms.host=MYSERVER2

This value should be MYSERVER1.

The Config Tool shows that the property <\cluster data\node\managers\ClusterManager>\ms.host has the value MYSERVER1. I have searched in the Config Tool and cannot find any references to the value MYSERVER2 anywhere.

Please can you tell me how the file:

T:\usr\sap\ABC\DVEBMGS00\j2ee\cluster\instance.properties

gets updated?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jul 26, 2009 at 09:15 AM

    Hi Paul,

    If you want to understand how instance.properties file update then check below link:

    http://help.sap.com/saphelp_nw04/helpdata/en/81/df5641998e061de10000000a155106/content.htm

    Second thing when you have found that there is problem in instnace.properties file then take a backup of this file and manually edit this file. Then try to start your system.

    And i think you can edit this file, check SAP Note 1287292 - JSPM and missing parameter at instance.properties file. In which in case of one error they suggested to edit instance.properties file after taking backup.

    Thanks

    Sunny

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I found that there was another property that was incorrect in the offline configuration tool. I have corrected it and it is okay now.

      Thanks for your help.

  • avatar image
    Former Member
    Jul 30, 2009 at 01:49 PM

    Hi Paul,

    Which property did you finally changed to make it work?

    Kind Regards

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I amended the UME configuration parameters in configtool->switch to the configuration editor mode->configuration->cluster_data->server-> cfg> services-> Propertysheet com.sap.security.core.ume.service

      The configuration file was missing. So I imported the configuration file and then restarted the engine.

      I didn't keep a record of the exact changes.

  • avatar image
    Former Member
    Feb 05, 2014 at 01:29 PM

    Although this issue is almost 4 years old, i recently had the same one.

    Thanks to Paul Richardson I managed to solve it.

    I changed the following things in the ./offlinecfgeditor.sh:

    • Configurations > cluster_data > Propertysheet instance.properties (as see above)
      • instance.box.number
      • instnace.en.host
    • Configurations > CTC > Propertysheet System.Properties
      • BACKEND_SYSTEM
      • J2EE_SYSTEM
      • SLD_GWHOST
      • SLD_HOST
      • TTCENTRAL_SERVICES_HOST
      • TTINSTANCE_HOST
    • Configurations > destinations > WebService > Propertysheet FP_ICF_DATA_<SID>
      • URL
    • Configurations > destinations > WebService > Propertysheet sap-com$2ftc~wd~pdfobject...
      • URL

    Furthermore i did this:

    • Open for edit go script from /usr/sap/<SID>/<instance#>/j2ee/JSPM directory
    • Locate the line:  rootdir=`dirname "$0"`
    • Change rootdir parameter to: rootdir=/usr/sap/<SID>/<instance#>/j2ee/JSPM

    Beyond:

    • cd /usr/sap/SMT/DVEBMGS91/j2ee/JSPM/data/variables/
    • rm Jspm.DataModel.xml Jspm.J2EE.DataModel.xml Jspm.JSPM.DataModel.xml

    In the configtool I changed the following things:I checked to see whether the right Database Host existis in the following Managers:

    • Cluster-data > Global Dispatcher configuration > managers > ConfigurationManager
    • Cluster-data > Global Dispatcher configuration > managers > LockingManager
    • Cluster-data > Global server configuration > managers > ConfigurationManager
    • Cluster-data > Global server configuration > managers > LockingManager
    • And for every Instance that is managed via the configtool as well.

    At the end I restarted the whole SAP-System (ASCS, SCS, DB …)

    As one could see we are using Linux. Hope it helps somebody!

    Add comment
    10|10000 characters needed characters exceeded