Skip to Content
avatar image
Former Member

soamanager referencing wrong port number in wsdl document

Hi,I have a question with web service.

I configured my web service in soamanager and it produced wsdl document.

http://client.com: 443/sap/bc/srt/rfc/sap/zgetuser/230/zgetuser/zgetuser" />

The port they gave for J2EE server is 80 in SOAManager....But in the wsdl produced port no is 443.

how to make that run over port 80?

I donu2019t know how I can correct and I donu2019t know why it produce wrong address.

Plz give your views

Thanks

Ganesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 03, 2009 at 01:17 PM

    Hi Ganesh,

    Your URL generates an HTTP on port 443. Port 443 is only used for HTTPS.

    If you change HTTP to HTTPS, what happens?

    Have you tried to manually adjusting the URL to what you believe is right?

    Check SMICM and then Services. Here you should see whether your system is running on HTTP or HTTPS.

    Within SOAMANGER you can change the J2EE settings via 'System Global Settings' and than tab 'Access Information J2EE Server'. Within this tab you can edit your settings.

    Regards,

    Nick

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 25, 2009 at 12:16 PM

    SAPNOTE 1263112 will solve your issue

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Schultz

      I have already found this note and it was resolved...so I closing this thread

      Thanks

      Ganesh

  • avatar image
    Former Member
    Jul 23, 2009 at 06:03 PM

    Any updates plz.?

    Add comment
    10|10000 characters needed characters exceeded