Skip to Content
author's profile photo Former Member
Former Member

NetWeaver Application Server CE7.1 Servlet Timout

Hello,

several Servlets, EJBs and WebServices are running on my NetWeaver Application Server CE 7.1. But if I call some of them, I receive a timeout error:

500 Connection timed out


--------------------------------------------------------------------------------
Error: -5 
Version: 7010 
Component: ICM 
Date/Time: Wed Jul 22 10:37:01 2009  
Module: icxxthr.c 
Line: 4193 
Server: server_CE2_00 
Error Tag: {-} 
Detail: Connection to partner timed out after 600s

How can I set the timeout manually?

Thank you in advance!

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 22, 2009 at 09:21 AM

    check this,

    http://help.sap.com/saphelp_nwpi71/helpdata/en/48/7f732201dd2722e10000000a42189d/content.htm

    ICM / Web Dispatcher Prioritizing

    If parameter icm/HTTP/error_templ_path is not set, the ICM static error page is always returned.

    If parameter is set, when error <ERRNAME> occurs, the ICM or Web dispatcher first checks whether file ICMERR<ERRNAME>.html is located in the directory specified byicm/HTTP/error_templ_path, and sends it to the client. If it cannot find this file, it searches for ICMERR<ERRNAME>.shtml and returns it.

    In no specific error page can be found, the ICM returns the default error page ICMERR-EDEFAULT.{html,shtml} (as above). If this file also does not exist, the static page is returned.

    Regards,

    Ravi

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 22, 2009 at 09:47 AM

    Hi Ravi,

    thank you! Where can I set the this parameters?

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 22, 2009 at 10:42 AM

    Here is the solution: http://wiki.sdn.sap.com/wiki/display/JSTSG/%28JSTSG%29%28Web%29Problems-P102 . But the property "icm/server_port_0" doesn't exists in my profile config file. What can I do?

    Thank you!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.