Skip to Content

Depreciation calculation working fine only if acquisition date is after 15 of every month

Hi All

We have configured mid month calculation for all company codes i.e.General depreciation system for US company codes & Alternative depreciation system for non US company codes. This is applicable to only tax depreciation area which we created. The following are the steps we did-

a) Created new depreciation area.

b) Assigned 24 (standard, hope this won't cause any issue) fiscal year variant at new depreciation area.

c) Added entries in Tcode-OAVH.

maintain-period-control-1.jpg

maintain-period-control-2.jpg

d) Created new depreciation key with base method 0007, decline balance method-001,period control-006 (03/03/03/03) & multilevel method- 044 (APC,any life).

However if our acquisition date is less than 15 of the month it is starting depreciation from1st date of the month (incorrect) & if date is after 15 of the month it is starting depreciation from 16th of the month. For example- If acquisition date is 07/04/2018 it is calculating depreciation from 07/01/2018 but if the date is 07/17/2018 it is starting depreciation calculation from 07/16/2018 which is correct.

Can someone pls advice if I m missing any step? The depreciation should start calculation from 16th of the month no matter what is the acquisition date. For example- Whether acquisition date 1 or 7 or 10 or 16 or 25 the depreciation should start from 16th of the month.

Regards

Pankaj

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Sep 28, 2018 at 11:35 PM

    Hi Pankaj,

    Please check Tcode OAVH. I think here you can customize the behavior for period control you are describing.

    Hope it helps.


    Regards,

    Filipe

    Add comment
    10|10000 characters needed characters exceeded