Skip to Content
0
Former Member
Jul 21, 2009 at 05:24 PM

XML Map update problem. Mod Please help.

48 Views

Hi, I took over an Xcelsius proj. The older developer had to leave. The problem is that there is an xml file that feeds data to different fields across many sheets. In the data manager definition this XML excel map is set to refresh on load, this was not happening; what I did was right clicked on a mapped xml field in excel (within excel) and said refresh data. It gave me an error saying Data source not found. It was pointing to a file at location in localhost. what I did next is just right clicked the xml mapped field and import and typed the full path of the file, it worked as supposed to and updated the data. But next time when the data was changed in the xml file it did not pick up the new changes. I had to manually right select the xml map cell(any mapped cell) and select refresh data and it did.

I also tried hard coding the file address in the data connection , also linked it to a cell where I posted the file address did not work.

The only thing that worked is that when I rclk and say import on the excel mapped cell and deleted the excel map from data manager and added it again it works fine and updates at runtime(refresh every 5 sec) but it breaks 95% of the components strangely and the components though mapped the right data cells show random data.

Please tell me of a way by which I do not have to always come to the source and clink refresh xml data or remap everything as this is a very complicated proj with many many layers + components.

Also tried something since last update

delete xml map in data manager

right click the xml mapped field(random)

selected import and pointed to the xml file

rename the data xml map

came back and previewed data worked fine (without refreshing data)

added the xml map in data manager (not selected refresh option-preview worked fine

checked the refresh on oad option -preview goes mad displaying random data from cells not mapped to respective components

went back to data manager and unchecked the refresh option-preview worked fine

added the connection refresh button- previewworks fine till refresh button is clicked which then causes random dat to be displayed

Edited by: Xcelsius_dev on Jul 21, 2009 7:24 PM

Edited by: Xcelsius_dev on Jul 21, 2009 8:56 PM