Skip to Content

TA ANST no longer works for Webdynpro ABAP Application Configurations after EHP7 upgrade

Hello folks,

this is the my first question since the migration has swallowed so many functions I held dear (ohmygodImsoexicted), here goes!

We have recently upgraded our ERP environment from ECC 6.06 to ERP 6 EHP 7 HR RENEWAL 2, Basis Stack 15, SAP_HR 608/0032, EA_HR 608/0032. Ever since, it seems no longer possible to create a trace for Webdynpro ABAP Application Configurations with the tool ANST, which is a shame as we have grown quite addicted to using it ;-)

I have searched for notes and also ran TA ANST for ANST itself, subsequently implementing the notes 2295368, 2300367, 2323931, 2361155 from the search results. These notes didn't address my exact problem and alas didn't affect it either. Let me elaborate on the problem:

After Launching a WD App Conf from ANST...,

...doing 'stuff' in the launched application, closing the browser session and stopping the trace...

...there is an info-message thrown...

...saying "trace interrupted by user". At this point, back when it still worked, instead of the message, ANST would build the trace file and automatically navigate to the next screen from which you can then search for notes, investigate modifications and so on. However, now, after the said info-message is thrown, "nothing" happens and I'm back on the initial screen. I attempted to debug and can at least see that there doesn't seems to be a hard error or the like (unfortunately), instead there is simply no trace input - that's at least what I think.

I double-checked that this isn't a configuration problem (would also be far-fetched, since it worked before the upgrade and our customizing for ANST has not been touched).

I also raised a customer Incident with priority "low" for SAP with pretty much the same content as this question, in case any of the ANST-Gurus read this.

Does anybody have or had similar issues or maybe got an idea what might go wrong all of a sudden?

Cheers, Lukas

P.S. Is there still a way to tag people on the new platform? *tries to magically summon Manoj Kumar*

anst-1.png (26.4 kB)
anst-2.png (15.0 kB)
anst-3.png (9.4 kB)
anst-4.png (13.8 kB)
anst-5.png (53.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Mar 31, 2017 at 11:33 AM

    For those who care: The problem has been solved with help of the SAP Support. There was a misconfiguration in TA FILE for the Windows NT path for ANST's Global Trace which caused the problem which is especially spooky and easy to miss because all our Servers run on Linux/Unix -_-

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Lukas,

      We are facing the same issue as yours. Can you elaborate on how you got it fixed? We checked the FILE transaction and changed the file location to our local application servers for both WINDOWS NT and Unix, but didn't help.

      Thanks for your help.

      Regards

      PK

  • avatar image
    Former Member
    Nov 16, 2016 at 11:27 AM

    Hi

    Check the sap note mentioned below...

    https://launchpad.support.sap.com/#/notes/0001885730

    If this does not solve the issue, please raise a ticket to SAP.

    Regards

    Prithviraj.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 16, 2016 at 12:06 PM

    This note is obviously not valid for my system (I did state which system I am on). Also, I already did extensive search for corrections and implemented quite a few (which I also stated in my Q). Furthermore I already raised an Incident for SAP, which is also stated in my Q. I wished you had at least read my question before answering... Here's one thing that hasn't changed after the migration..

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 16, 2016 at 12:35 PM

    Hi,

    My bad.. I should have read the Q till the end.

    sap note 2286869 is the one that has the solution to your issue but, as you are already on SP15 the issue should have been corrected.

    I guess then SAP can only assist here, if someone else have solution to it otherwise.

    Regards

    Prithviraj

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 16, 2016 at 02:24 PM

    It's Okay. I have to apologize, actually for ranting against you like that :-/, I'm just majorly grumpy because of 1 billion issues we got after our EHP upgrade plus the Support Launchpad goes haywire and ANST goes haywire diminishing my support tools available, creating problems I have because of other problems because of other problems <insert recursion here>.

    Yes, 2286869 is already implicitly included in the SP Level and all subsequent notes available I have already implemented. So I'll have to hope SAP picks up my ticket. Maybe I can manage to ping one of the Devs haunting the forums, if I manage to find out how I do that on the new platform ~_~

    Cheers, Lukas

    Add comment
    10|10000 characters needed characters exceeded