Skip to Content
avatar image
Former Member

HTTPS XI adapter

Hi,

I am trying to sending some message via XI adapter to my partner using https. I am getting below error but if my partner sender communication channel send to http then it successful. My problem is im send using https and tested the connection using sm59 but when send using xi adapter it become http. Any idea?

http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>XIServer</SAP:Category>

<SAP:Code area="SECURITY">INBOUND_SECURE_LEVEL</SAP:Code>

<SAP:P1>25818A00B5DF4E9A0C57B463E10C74E7</SAP:P1>

<SAP:P2>HTTP</SAP:P2>

<SAP:P3>HTTPS Without Client Authentication</SAP:P3>

<SAP:P4 />

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>Message 25818A00B5DF4E9A0C57B463E10C74E7 was sent with 'HTTP'. Channel configuration, however, requires 'HTTPS Without Client Authentication'</SAP:Stack>

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jul 17, 2009 at 02:23 PM

    Hi,

    Let me first try to put my understanding of the problem statement

    1. You want to send a message to a partner via HTTPS without Client Authentication using HTTP receiver adapter. This is throwing errors.

    2. Your partner is sending a message to XI via HTTP. This is working fine.

    3. You have tried configuring an RFC destination in SM59 and then tried sending the message via HTTPS using HTTP adapter. It worked.

    I have a doubt here. Did you use the same parameters in the SM59 destination that you have used in the receiver HTTP channel while sending the HTTPS message directly? Then there should not be any difference.

    In the second step, since your partner is able to access the XI machine via HTTP, then even you can call him on HTTP. If the communication between you and your partner is HTTPS, then it will be HTTPS both ways. It cannot be HTTP while receiving and HTTPS while sending.

    If my understanding is incorrect, kindly provide more details on the problem statement

    Thanks and Regards,

    Sarath.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 14, 2009 at 02:54 AM

    There was s mistake on firewall setting.

    Add comment
    10|10000 characters needed characters exceeded