Skip to Content
author's profile photo Former Member
Former Member

How to replace comma "," with dot "." and "." with "," in Payslip Values

Hi,

I am using payroll india. But in payslip values dot "." is coming instead of comma "," and comma "," is coming instead of "." , that is not correct notion for indian payroll. So plz help me how i convert this notion.

For example... In inda we generally write 25,000.500 (Twenty thousand and five paise) but In SAP this value is showing like 25.000,500

Mukul

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • Posted on Jul 16, 2009 at 06:49 AM

    Hi Mukul,

    Goto SU3 transaction & DEFAULT Tab.

    Maintain the decimal notation as per your requirement & SAVE.

    Thanks,

    Best regards,

    Prashant

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2009 at 07:08 AM

    Hi Mukul,

    This is s user specific setting and you can easily set it for your ID by doing the following:

    Go to t-code SU3.

    Go to Defaults tab

    Set the value for 'Decimal Notation' from the dropdown value that meets your requirement.

    Regards,

    Saumya

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2009 at 07:23 AM

    Hi ,

    if you are in SAP screen goto system option in menu , system --> user profile --> owndata , once you are in the screen click on

    default tab and change according to your requirement.

    Please let me know if you still need any more help.

    Thanks and regards,

    Rajeshwar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2009 at 10:03 AM

    REPLACE ',' IN FIELDNAME WITH '.'.

    BY

    IMUTHU.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2009 at 10:12 AM

    Hi,

    Use in this way...it'll satisfy ur requirement

    v_amount = 123.00,56

    TRANSLATE v_amount USING ',..,'

    after this statement

    v_amount = 123,00.56

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2009 at 10:20 AM

    Hi Mukul,

    This is happening because of your / end user's specific user settings.

    Go to SAP Easy Access -> System -> User profile -> Own Data.... here you will find three radiobuttons for changing the date format.

    Go ahead and choose the best one for you.

    Hope this helps! Pls provide feedback if helpful!!

    Cheers,

    Shailesh.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2009 at 10:21 AM

    Hi Mukul,

    As several people have said, this is a user profile option under the defaults tab (you can set decimal, date format etc here).

    Note: If the payroll is being run by a background user, ensure that the option is set for the user ID associated to the payroll run.

    Good Luck!

    Robin

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.