Skip to Content
0
Former Member
Jul 15, 2009 at 02:28 PM

Crystal Reports error - The Report Application Server failed

394 Views

Hi,

I am getting the following error on XP Professional system. These reports were built earlier by one of my collegue and am trying to use the app but i stuck up getting the below error. The report gets failed

repPath=Server.MapPath ("./Reports/Umbrellas.rpt");

crReportDocument.Load(repPath); //Fails here

crReportDocument=SetLogonForReport(crReportDocument);

crReportDocument.SetParameterValue ("fromDate",DateTime.Parse (fromdt) );

crReportDocument.SetParameterValue ("toDate", DateTime.Parse (todt) );

I tried in design time attaching to Crystal Reports Viewer object , i get the same error. It looks like something related to Crystal Reports got corrupted in this system.

Please find the stack trace for the error

Stack Trace:

[COMException (0x80004005): The Report Application Server failed]

CrystalDecisions.ReportAppServer.ClientDoc.ReportClientDocumentClass.Open(Object& DocumentPath, Int32 Options) +0

CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.Open(Object& DocumentPath, Int32 Options)

CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.EnsureDocumentIsOpened()

[Exception: Load report failed.]

CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.EnsureDocumentIsOpened()

CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String filename, OpenReportMethod openMethod, Int16 parentJob)

CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String filename)

CrystalDecisions.ReportSource.NonHTTPCachedReportSource.GetReport(RequestContext context, Boolean bAddToCacheWhenCreated)

CrystalDecisions.ReportSource.LocalReportSourceBase.GetPage(PageRequestContext pageReqContext)

CrystalDecisions.Web.ReportAgent. (Boolean o)

CrystalDecisions.Web.CrystalReportViewer.OnPreRender(EventArgs e)

System.Web.UI.Control.PreRenderRecursiveInternal() +62

System.Web.UI.Control.PreRenderRecursiveInternal() +125

System.Web.UI.Control.PreRenderRecursiveInternal() +125

System.Web.UI.Page.ProcessRequestMain() +1488

Environment:

.NET v1.1.4322

Crystal Reports 10.0.0.533

OS: Windows XP Professional - Ver 2002 Severice Pack 2

I tried some of the solutions provided by searching web, it does not work. Please help!!!

Appreciate your help on this.

Edited by: KMallik2000 on Jul 15, 2009 4:39 PM