Skip to Content
author's profile photo Former Member
Former Member

Project role definition not possible

Hi experts,

has anyone an idea to really enable the ressource management of a new installed cprojects 4.5 system (without WFM-Server)? I did use the ressource management in cprojects last year at a cp 4.0 installation but this time it doesn't work at all.

We have two unsolved questions which should belong together:

I. Two errors when you start cProjects: "Communication with the WFM Core system is not possible" and "WFD not yet converted". But the WFM-/WFD-Server is not intended to be used. There should be no messages (see customizing).

II. The complete area of ressource management in cProjects is empty and gray - no possibility to define any new project role and there is no predefined project role. It is possible to define project structures using different project types.

The system: cProjects 4.5, latest SP and IDES SAP ECC 6.0

Used roles / profiles: SAP_CPR_PROJECT_ADMINISTRATOR / SAP_All

Customizing concerning project roles / WFD:

1. Resource Management > Workforce Deployment Server > Dispatcher Settings > Switch between liveCache and BuiltIn-Dispatcher:

active built in dispatcher defined in dispatcher settings (not the liveCache option).

2. Resource Management > Basic Settings for Project Roles > Define Project Role Types:

no use of WFD-Server in the defined project role types.

3. Resource Management > Qualification Management > Active Qualification Search...:

no User Qualification Comparison of WFM Core (Value abbr. empty).

Hopefully someone can help me with ideas, solutions or documents.


Christoph Lange

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 15, 2009 at 11:10 AM


    Check this note:  1039443 

    Also there are few authorization for WFM which you are not using but if your Basis activates then add S_RFC

    You can check the authorizations in SAP_CPR_USER

    These were not there for 3.1


    Edited by: Niranjan Dandekar on Jul 15, 2009 4:41 PM

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Just for info:

      We just found the answer in another notification - running an xpra was needed:

      ... From my observation based on the above descriptions, you have upgraded

      WFM Core from 110 to 200. But you have not run the xpra: /SAPAPO/WFD_

      XPRA_20 after upgrade. WFD server cannot be used untill xpra: /SAPAPO

      /WFD_XPRA_20 is run.


      Christoph Lange

  • author's profile photo Former Member
    Former Member
    Posted on Aug 11, 2009 at 10:26 AM

    We disabled WFM Core on our cProjects 4.5 using this steps:

    1. Enhancement spot CPRO_WFM

    a) Use transaction SE18 to create the enhancement spot CPRO_WFM with the short description "cProjects: WFM Integration" in the package PRP_WFM.

    b) Create the BAdI DPR_WFM with the short description "cProjects: WFM Integration"

    c) Select the specification "Reusing Instantiation" as the instance creation method and expand the node DPR_WFM in the tree on the left.

    d) Double-click "Interface", enter the interface IF_EX_DPR_WFM on the detail screen on the right, choose "Change interface", confirm the dialog box with "yes" and create the interface in the package PRP_WFM.

    e) Save the enhancement spot.

    f) In the interface, enter the public method IS_WFM_CORE_ACTIVE with the description "Is the WFM core active?" and add the following parameters:

    Parameter RV_NOT_ACTIVE

    Type Returning

    Pass value X


    Typing Method Type

    Associated TypeXFELD

    Default value

    Description "WFM core is not active ('X' = yes, ' ' = no)"

    g) Activate the interface and the enhancement spot.

    2. Implement the attached correction instructions and activate all relevant program objects.

    3. Use transaction SE19 to implement the enhancement spot CPRO_WFM.

    Hope it will be usefull.

    Edited by: Alex Valchuk on Aug 11, 2009 12:27 PM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.