Skip to Content

WEBIDE - Deploy to SCP does not work with ES6

Hi,

I am trying to deploy my custom UI5 application to SCP, via WebIDE (Full Stack) but it fails during BUILD due to ES6 JS code.

Removing ES6 code and replacing with ES5 means the build works fine with no issues.

Uglify issue perhaps? The build console log is not very clear.

Cheers,

James

Add comment
10|10000 characters needed characters exceeded

  • Web IDE now supports deploying with ES6 syntax when 1.3.65 of @sap/grunt-sapui5-bestpractice-build is applied. Updated my answer accordingly.

    Since this issue is resolved now officially (no workarounds needed), I'd suggest to close this question.

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 16, 2018 at 05:48 PM

    > Uglify issue perhaps?

    Yes, see https://stackoverflow.com/a/52841062 for explanation.

    Update: As of "@sap/grunt-sapui5-bestpractice-build": "1.3.65", the below workaround is no longer needed!

    ________
    Earlier answer:

    For now, you can add "grunt-openui5": "0.15.0" to the package.json file in order to enable deploying with ES6 syntax.

    {
      "name": "...",
      "version": "0.0.1",
      "description": "...",
      "private": true,
      "devDependencies": {
        "@sap/grunt-sapui5-bestpractice-build": "1.3.62",
        "grunt-openui5": "0.15.0"
      }
    }

    To check the latest version of grunt-openui5, run:

    npm view grunt-openui5

    Or just visit this npm page.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 31, 2018 at 05:17 PM

    Hi James,

    Have you done the steps described on this blog? There is also a simplified blog that tackles just the jlint errors here.

    Best regards,
    Ivan

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 17 at 10:20 AM

    In this blog I describe why Ivan's answer might be the better (but more advanced) choice.
    Ivan refers to this blog which basically contains three simple steps.

    Add comment
    10|10000 characters needed characters exceeded