Skip to Content
avatar image
Former Member

skipping disabled step in GAF

Hello All,

I am disabling a main step in a GAF FPM at runtime by calling method IF_FPM_GAF->enable_mainstep in the OVERRIDE_EVENT_GAF method of interface IF_FPM_GAF_CONF_EXIT.

However, the step is still being called when it is reached.

Moreover, the step is automatically re-enabled this.

Does anybody know if this is normal behaviour?

And if so, is there an efficient way of programming this in?

I suppose I could trigger a 2nd next_step event in the before_flush of the application controller to skip it, but will need to suppress any event processing validations for the relevant uibbs.

Many thanks for any advice,

Pieter

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jul 14, 2009 at 07:57 PM

    Hi Pieter, I am trying to do something similar. Can you provide the code and details of how you instantiated the IF_FPM_GAF interface?

    Thanks,

    Zack

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Zack,

      If you implement interface IF_FPM_GAF_CONF_EXIT in your component, you receive the instance as parameter of the method OVERRIDE_EVENT_GAF.

      In your GAF configuration you need to set your component in the Global settings or it won't be called. (Change button just above the Hierarchy view on the left side > Global Settings and set it in the first field in the popup)

      Hope this helps,

      Pieter

  • avatar image
    Former Member
    Jul 15, 2009 at 06:39 AM

    If you will always not need this step, then you can just create a new varaint for this application and leave that UIBB out. But in case you want to skip it, then you will need to raise the next_step. Since you will not raise any events in this UIBB what would be the need to do the validation?

    - Harish

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Harish,

      I do sometimes need the step - that's why I'm disabling it dynamically.The validation is there for the cases when I do need it.

      Somehow I would have expected the FPM to have the intelligence to know by itself to skip a step that is disabled.

      That's why I was wondering if maybe I was doing something wrong...

      I've managed to do it now by raising the next_step event in the before_flush as I already suggested myself, but this is more work as I would have liked it to be - I even need to re-disable it as the next_step apparently reenables it.

      Regards,

      Pieter