Skip to Content
author's profile photo Former Member
Former Member

EHP4 installation - Could not connect to port 4240

Hi,

I am trying to complete my ECC6 EHP4-ready installation by installing

Enhancement package 4 with EHPI tool.

In the initial Extraction phase Import tools (TOOLIMPI) the

installation gets stuck for long time and doesnt progress. When I stop

it Imanually I see this:

Jul 8, 2009 5:03:11 PM [Error]: Unable to execute the SDT request ABAP

operation extract on hostname degtlun1141 instance 33

Then, I see this error in the sdt trace directoty under the

installation folder:

/EHPI/sdt/trc

Here is the error in the file server.trc:

Jul 8, 2009 4:07:46 PM [Error]:

com.sap.sdt.lup.ctrl.SDTRequestExecutor.invokeMethod

(SDTRequestExecutor.java:267) [Thread[ABAP-3,5,main]]: Unable to

execute the SDT request ABAP operation extract on hostname degtlun1141

instance 33

Jul 8, 2009 4:11:27 PM

[Error]:

com.sap.sdt.sapup.rapi.connector.R3upConnector [Thread[ABAP-3,5,main]]:

Could not connect to degtlun1141:4240. Could not connect to host

degtlun1141 on port 4240.

java.net.ConnectException: Connection refused

java.net.ConnectException: Connection refused

When I do a netstat for this port, I see that it is used at the time but by

the EHPI itself because when I stop it the port shows no activity again.

How to proceed i this case?

Thanks

Cyrus

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Posted on Jul 09, 2009 at 08:40 AM

    Hi,

    Before starting EHPI, check this port and if it is in used then kill that process. Then start again EHPI

    We have faced this problem and problem was another system on this host is using that port.

    Thanks

    Sunny

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Erick,

      Fantastic analysis!

      Long years have gone since you created this post, but it is still relevant; it saved my upgrade from a reset....

      Minor changes for the benefit of all:

      • SUM (version 1.0 SP10), instead of EHPI
      • Upgrade of ERP6.0 from EhP6 to EhP7
      • Step 5.5, Pre-Processing, phase MAIN_SHDIMP/READPUTTB_REST
      • Error faced ---> *** FATAL ERROR: Unterminated word in '"'


      The last line of file CONPUTTBSHD.TAB was corrupted, which was replaced by corresponding entry from CONPUTTBSHD.SAV.

      Thanks again for your post!

      Shaji

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2009 at 02:48 PM

    Hi Sunny

    I have the same problem with port 4240. Other instances is stoped, netstat shows that port is free, but ehpi stops with error:

    Could not connect to host <hostname> on port 4240

    Can you help to fix this problem? Thanx

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2009 at 12:31 PM

    Hello Cyrus

    hopefully the problem is already solved but if you still facing Problem with missing JAVA or ABAP Server request be sure that firewall applications are not disturbing your work or processes e.g "java visual admin" or/and "config.tool" are already occupying the requested service port. rarly some network folder connections towards the solution manager could be missing due to hardware reboot or network failures.

    please let the crowd know if some of suggestions were helpfull

    kind regards

    Oliver

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Oliver,

      How did you solve it?

      In my case there is not any service using port 4240 (reviewed by netstat), the server doesn't have a firewall running and visual admin & configtool are using default ports...

      Moreover, the installation was running fine before the OS (windows) was restarted. I also have a customer message since last July 28th, but it is still with status "Sent to SAP". As it is an installation on a sandbox the priority is low... may be this is the reason why SAP has not answered yet.

      Any help will be appreciated.

      Regards,

      Erick Acosta

  • author's profile photo Former Member
    Former Member
    Posted on Sep 15, 2009 at 07:49 PM

    We also are getting the same error.

    Did a lsof -i :4240 at the OS and it doesnot return anything which implies that port is free.

    Did you start the EHPI

    - /EHPI/STARTUP "jce_policy_zip=90000125.ZIP" command in one session and then use

    - http://<hostname:4239/ or start the GUI in another session?

    We are also facing the same issue where EHPI is failing at the extraction phase with error

    -


    Unable to execute the SDT request ABAP operation extract on hostname

    <hostname> instance 00

    Extraction of the ABAP upgrade request ABAP has failed

    Error from unit observer Tool connector failed.

    Connection to SAPup could not be established, see following messages.

    Could not connect to host <hostname> on port 4240.

    java.net.ConnectException: Connection refused

    java.net.ConnectException: Connection refused

    -


    Any help will be highly appreciated.

    Thanks

    Kalinga

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 18, 2009 at 12:45 AM

    Hey Guys:

    We got this solved by changing the location on the EHPI installion directory. Initially I had the issue as the EHPI was located in a

    file systems /XXXX/XXXXXX/XX which was much longer that 25 characters.

    ..../EHPI/INSTALL was failing stating that the path is more than 25 character. So we created a soft link and the INSTALL script started but when the GUI/ Weblink to start the actual installation was troggered it failed with this error:

    *******************Could not connect to port 4240. ***********************

    To fix that we just created a different physical file system /EHPI in our Unix box and did all actvities there and things went like a charm.

    Another point - - Note 1260665 - Error in upgrade phase MAIN_SHDCRE/RUN_RSDBSCPY ...Make sure you have this note applied before you start the whole shebang with notes to avoid the mass activation error in -

    MAIN_SHDRUN/ACT_UPG phase of EHP application. If not applied prior to the start you will have to manually do it in the shadow instance .

    Hopefully if any one gets this issue, it helps him.

    Thanks

    Kalinga

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 04, 2011 at 11:17 AM

    Hi everybody, thought I would share how I got the same problem fixed whilst doing EHP5 upgrade:

    My upgrade went into Downtime Phase but failed on step MAIN_SHDRUN_ACT_UP. After searching the logs I found the same error that it couldn't connect to hostname:4240. So I have also stopped and restarted everything, but still the same error. Also netstat didnt show any port 4240 being used when EHPI was stopped, but did show it used when starting the EHPI. After lots of frustration and following info from this forum I finally decided to run the WebGui for EHPI on another machine, and then it worked!

    This was for Solaris, so I started an XManager session to the desktop, ran STARTUP script from there and then on the same Solaris Desktop (XManager session) started Mozilla Firefox to access hostname:4239 and run SDT from here. All of this worked fine when I did our development server, but on Qas it gave me hassles. So for Qas I also opened an XManager session to the Solaris Desktop, started the STARTUP script but then opened an Xmanager Session to the Dev Desktop and ran the webbrowser from there to start the SDT.

    All worked fine from here!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.