Skip to Content
0
Former Member
Jul 02, 2009 at 11:42 AM

Error when connecting to portal : Message: Dispatcher running but no server

35 Views

<br>Hello everyone</br>

<br>

I searched a lot on SDN for an answer to my problem but i couldn`t find any solution. Till yesterday the portal worked OK.. no errors untill this one, but from yesterday when i try to connect i received this error:

</br>

<br>

SAP WebAS Engine is starting...

</br> <br>

If this state does not change within a few minutes,

please contact your system administrator.

Check the recommendations in SAP Notes: 943498, 764417

<br> </br>

Message: Dispatcher running but no server connected!

Details: No details available

</br>

<br>

I read all SAP Notes regarding this problem and i couldn`t find any solution which would fit for me.

From SAP Notes i found out that i need to analyse some logs .. here is what i found in the logs:

</br>

<br>

<p>

On stderr2 file:

[Thr 01] MtxInit: 30002 0 2</br> <br>

The java class is not found: com.sap.engine.offline.OfflineToolStart</br> <br>

The java class is not found: com.sap.engine.offline.OfflineToolStart

</p></br>

<br><code>

On dev_jcontrol:

[Thr 01] Thu Jul 2 11:54:43 2009

[Thr 01] JStartupICreateProcess: fork process (pid 1863782)

[Thr 01] JControlICheckProcessList: process server0 started (PID:1863782)</br>

<br>

[Thr 01] Thu Jul 2 11:55:08 2009

[Thr 01] JControlICheckProcessList: process server0 (pid:1863782) died (RUN-FLAG)

[Thr 01] JControlIResetProcess: reset process server0

[Thr 01] JControlIResetProcess: [server0] not running -> increase error count (4)

[Thr 01] JControlICheckProcessList: running flight recorder:

/usr/java14_64/bin/java -classpath ../j2ee/cluster/bootstrap/sap.comtcbloffline_launcherimpl.jar

com.sap.engine.offline.OfflineToolStart com.sap.engine.flightrecorder.core.Collector

../j2ee/cluster/bootstrap -node ID8477250 1246524883 -bz /usr/sap/BIP/SYS/global

</code></br>

<br><code>

On dev_server0:

[Thr 39324]

*****************************************************************************

*

[Thr 39324] * LOCATION CPIC (TCP/IP) on local host

[Thr 39324] * ERROR illegal parameter value ( function=SAP_CMTIMEOUT2 /

  • parameter=conversation_ID / value=17508060 )

[Thr 39324] *

  • TIME Thu Jul 2 11:55:04 2009

[Thr 39324] * RELEASE 700

[Thr 39324] * COMPONENT CPIC (TCP/IP)

[Thr 39324] * VERSION 3

[Thr 39324] * RC 769

[Thr 39324] * MODULE r3cpic_mt.c

[Thr 39324] * LINE 7319

[Thr 39324] * COUNTER 2

[Thr 39324] *

[Thr 39324] *****************************************************************************

<br> </br>

[Thr 39324] JLaunchIExitJava: exit hook is called (rc = -11113)

[Thr 39324] **********************************************************************</br> <br>

  • ERROR => The Java VM terminated with a non-zero exit code.

  • Please see SAP Note 943602 , section 'J2EE Engine exit codes'

  • for additional information and trouble shooting.

**********************************************************************<br> </br>

[Thr 39324] SigISetIgnoreAction : SIG_IGN for signal 20

[Thr 39324] JLaunchCloseProgram: good bye (exitcode = -11113)

</br></code>

<br>

I read the notes.. but for my problem it is written .. please contact SAP Support..Have any one .. any idea about this problem? It`s is importan because it is the future PRD portal.. not yet with go-live.. and i do not wan`t to install it again.

</br>

<br>

Thank you

</br>

Edited by: Patrick Raileanu on Jul 2, 2009 1:43 PM

Edited by: Patrick Raileanu on Jul 2, 2009 1:55 PM