Skip to Content
0

Browse filed contains no data but data is available in DB

Nov 15, 2016 at 03:39 PM

19

avatar image

I have one report connecting to 2 databases. Then I made a SQL_Command in order to convert to number the field from one table. This converted filed is linked to a field from a table in the other database.

The problem is that when I press on "Browse SQL_Command" the data is displayed in a table, but if I press browse on a field in the SQL command, no data is displayed.

All databases are up to date.

The databases contain null values, but I have formulas such as:

if isnull {SQL_Command.LOCATION_DETAIL}
then "nicht zugeordnet"
else {SQL_Command.LOCATION_DETAIL}

So it finds the null and it displays "nicht zugeordnet". But only this field is displayed. (I am saying this because I read that CR stops when it finds new values)
However, I don;t know if this is the problem because I also tried nvl and concerted all null to 0. Still no data displayed.

And it makes sense not to display data since in "browse field" there is no data...

Do you have any solutions for this?

I am working in Crystal reports for Enterprise

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Brian Dong Nov 15, 2016 at 09:54 PM
0

Hi Bianca,

I believe there are no nulls in the data then. Try changing your formula to:

if isnull {SQL_Command.LOCATION_DETAIL} or {SQL_Command.LOCATION_DETAIL} = 0 then 
     "nicht zugeordnet" 
else {SQL_Command.LOCATION_DETAIL}; 

It will look for an empty string instead of a NULL.

Also, does the new number field in the SQL Command match the numeric data type in the linked table? Integer to Integer or Double to Double? If you converted to an Integer in the SQL Command but the number in the linked table is a Double or Large Int then it may not link properly.

Good Luck,

Brian

Share
10 |10000 characters needed characters left characters exceeded