Skip to Content
Jul 01, 2009 at 12:58 PM

DB2 Proceeses Terminated as a result of SGEN, and DBIF_REPO_INTERNAL_ERROR


Hello Friends,

I am facing one unexpected Problem as a result of SGEN or running any loaded work on SAP SOLMAN with DB6 9.1 FP5

Brief Information about the SAP system and DB2:

SAP System : SAP Solution Manager 7.0, SPs 15

SAP System Kernel:

(old) 700_185

(current) 701_15 (recently i have upgraded kernel from 700 to 710 release, with purpose of this problem resolution )

Operating System: Windows Server 2003 Enterprise Edition x64 Edition

Database : DB2 v9.1.500.555

(Old) FP4

(Current) FP5

DB21085I  Instance "DB2SMP" uses "64" bits and DB2 code release "SQL09015" with

level identifier "01060107".
Informational tokens are "DB2 v9.1.500.555", "s080512", "WR21410", and Fix Pack

Product is installed at "J:\db2\db2smp\db2_software\" with DB2 Copy Name

How Problem came into picture:

-> In starting phase , as a part of service Preparation Activity , I have applied ST-A/PI - 01L_CRM570 in Solution manager.

-> After that I run SGEN, It had run for some time, and suddenly SAP system was stuck and ended as DB2 related all process were killed at OS level. Means DB2 was stopped accidently as a result of SGEN

-> then I started DB2 using db2start command. It started normally.

-> I have seen that, last SGEN was still in ACTIVE state and was ended with DBIF_REPO_INTERNAL_ERROR & GEN_SOURCE_FORMAT Run-time Errors.

-> Then as a doubt, i patched DB2 and raised its FP level from FP4 to FP5, after following some SAP NOTES.

->Then again I started SGEN, but,it also ended with the same symptoms.

-> Then as a doubt, i patched SAP Kernel and raised its release level from 700(185) to 701(15), as normal kernel upgradation activity on windows system.

-> Again, i ran SGEN to get expected output, but still its ended with the same Symptoms. The Database was stopped accidently as a result of SGEN.

I am confused , why this is happening ?

Weather its pointing to Database Client's Doubtful functionality or not?

or due to Database inconsistency, this is happening?

My Regular Backup Activity is running successfully, without error and within its time.

May i know, where i am missing something?


Bhavik G. Shroff