Skip to Content
avatar image
Former Member

Errors generated when running batch anlysis report

Dear Guys,

When i run my batch analysis in the server, i keep seeing the error below generated in the logs:

Jul 1, 2009 3:49:36 PM com.virsa.cc.common.SAPAdapter serverExceptionOccurred

INFO: Exception in Server SLD_UC:

com.sap.mw.jco.JCO$Exception: (129) JCO_ERROR_SERVER_STARTUP: Server startup failed at Wed Jul 01 15:49:36 GMT+08:00 2009.

This is caused by either a) erroneous server settings, b) the backend system has been shutdown, c) network problems. Will try next startup in 3600 seconds.

Could not start server: Connect to SAP gateway failed

Connect parameters: TPNAME=SLD_UC GWHOST=localhost GWSERV=sapgw01

ERROR partner '127.0.0.1:sapgw01' not reached

TIME Wed Jul 1 15:49:36 200

RELEASE 700

COMPONENT NI (network interface)

VERSION 38

RC -10

MODULE nixxi.cpp

LINE 2513

DETAIL NiPConnect

SYSTEM CALL connect

ERRNO 79

ERRNO TEXT A remote host refused an attempted connect operation.

COUNTER 520

May i know what is the reason for the error and also what is the solution for this matter? I could not figure it out...

As the report is running very slow in the system, could this be one of the cause of the performance issue?

Appreciate your reply, thank you in advance.

regards,

wei how

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 01, 2009 at 11:14 AM

    Hi Lee,

    1. First of all, please give your server an IP address as it tries to connect via IP and log shows that it is connecting to localhost.

    2. SLD Server is not up and it is not pulling data from Backend system. check whether SLD is up and running.

    3. Have you tested JCo connection? Check if it is working. GRC Server name, IP and domain name should be maintained in host file. Backend system message serve entry should be in services file like -

    sapms<SID> 36<Instance no.>/tcp # for Message Server connectivity onto SRM Quality Server

    First check these setting if these are fine, specially your JOC is working fine.

    Regards,

    Sabita

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 01, 2009 at 11:20 AM

    Hello Lee,

    1) First of all check your GRC server's hosts and services files,

    The hosts file contains corrects IP address hostname of your backend system

    The services file contains correct sapmsSID & sapgw00 or 01 entries

    2) Check your SLD is correct.

    Go to http://hostname:50000/sld

    Administrator-> Profile -> select Section as Datasupplier, DataTrace to True,. GatewayHost to correct backend system hostname and GatewayService to the correct gateway service which you have given in the backend system while running rz70.

    Then check your issue id resolve or not.

    Regards,

    Sudip

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 01, 2009 at 11:58 AM

    Thanks for the reply.

    So in my services file i should enter the details of my backend system? and for the hosts file i need to enter the gateway details? Is that correct?

    I have checked my SLD and JCO connections, status is running and test was successful, the reports can be executed, i see progress in the batch job i triggered, its just i do not understand why is it so slow and also the mentioned error keeps popping out...

    Again, appreciate your replies, thanks!

    Regards,

    wei how

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Wei ,

      I am facing the same issue where I see the JCO_ERROR_SERVER_STARTUP: Server startup failed errors in the system logs. My JCO and SLD are working fine. How did you resolve this??

      Thanks