Skip to Content

Can one downgrade PowerDesigner Version

Hello, for some reasons I want to use 16.6.0.0 version but already have 16.6.5.4.

Please help if you can.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Aug 29 at 02:54 PM

    Hi,

    opening newer model in older PD (=downgrading) can lead to unpredictable damage in the models. Not necessarilly, but probably. What is the reason to downgrade?


    Ondrej

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 30 at 12:29 PM

    Hello, can you explain or give example what could happen? What kind of damage are we talking about?

    About your question, I'm just interested because I couldn't find anything in options nor settings as far.

    Thanks for your attention.

    Add comment
    10|10000 characters needed characters exceeded

    • If the underlying PowerDesigner metamodel has changed, or is managed differently in the model file, there could be problems when you open the file, which might or might not be obvious.

  • Sep 10 at 06:01 PM

    Hi,

    What you want to do is not possible. Please read the information from KBA: 2473042 - Is it possible to downgrade PowerDesigner - SAP PD

    Regards,

    Jesica

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 12 at 10:15 AM

    Some modelling tools allow you to save a model in an old format - I wish PowerDesigner could do that. I often have to send clients models saved by a newer software version than the one they have, So far, nothing bad has happened - they save the model in the old format, and carry on using it. I know that the PDM engine sometimes has significant changes, which would make this very risky, but that hasn't affected me so far, I don't send many PDMs to clients. I suspect the same issue could arise with the OOM and DMM from time to time.

    If you've got a repository and you want to go back to a previous tool version, then you're going to have a real problem.

    Add comment
    10|10000 characters needed characters exceeded