Skip to Content
avatar image
Former Member

UME provisioning error in IDM 7.1

Hi Experts,

While testing the UME provisioning task, I'm getting the following error:

Exception from Add operation:com.sap.idm.ic.ToPassException: Exception when creating user :Secure transport layer is needed to set a productive password

Is it because the connection protocol is HTTP and the task is expecting HTTPS?

I would appreciate it if you any of you could guide me on how to configure the secure transport layer between IDM and UME.

Thanks in advance,

Biju

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Aug 19, 2009 at 07:08 AM

    Hi Biju,

    We are facing the same issue now.

    We have integrated IDM7.1 with CE7.1 and while trying to create a user ID in CE7.1 system from IDm, we get :

    Exception from Add operation:com.sap.idm.ic.ToPassException: Exception when creating user :Secure transport layer is needed to set a productive password

    Please let us know, how were you able to resolve this.

    Thanks in anticipation,

    Kushal Agrawal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Siva,

      I need an help from you.

      Right now we are trying to integrate IDM 7.1 UMEWebdynpro project? (UI Customization needs to be developed only on IDM 7.1 version)

      Can you help me in guiding out this task?

      Thanks in Advance !!

      Regards

      MG

  • avatar image
    Former Member
    Aug 24, 2009 at 01:58 PM

    Hi Biju

    We are also facing the same problem. Have you found a solution?

    I have tried the https protocol - resulting in another error message:

    Exception from Add operation:com.sap.idm.ic.ToPassException: SPML exception: Error opening socket: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?

    BR

    Olaf Bertelsen, KMD A/S

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 24, 2009 at 03:04 PM

    It would seem SSL is required. I know SSL is required for setting the Password in AD and some LDAPs under most circumstances. Not sure if there's a setting to change this in SAP.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2009 at 06:57 PM

    Hi,

    To set a productive password for the UME, you will have to enable SSL between IC and UME.

    You can set an initial password for the UME by changing the attribute "passwordchangerequired" to "true"

    for the "Create UME User" task. This will set an initial password for the user instead of a

    productive password.

    -- Gee

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      where can I find the passwordchangerequired and set it true?

      I do not have this attribute. Do I have to create it? Do I have to create it in the global constants?

      BR Gerdi;-)

  • Aug 25, 2010 at 01:49 PM

    Hello,

    if you need to make the password that has been set by the IdM an productive password you can use parameter passwordchangerequired = false.

    But normally this is not recommended for security reasons.

    Hope that helps,

    Best regards.

    René Feister

    SAP Consulting Germany

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      i get the following error when creating a user with the Create UME User task.

      putNextEntry failed storingSPML.SAPUSER.dsb-testaccount
      
      Exception from Add operation:com.sap.idm.ic.ToPassException: Exception when creating user :Secure transport layer is needed to set a productive password

      Where do I have to set the parameter: "passwordchangerequired"?

      Normally the user should get the DEFAULT_PASSWORD from Global constants or am I wrong?

      kind regards

      push

      Sorry for pushing this topic, but I think some of you already got this issue solved.

      It would be very fine to get this working for my bachelor thesis...

      Could anyone help or guide me please what to do?

      Thanks in advance.

      edit

      got the workarround with passwordchangerequired to work.

      Edited by: SAP-3r1k on Aug 15, 2011 9:23 AM