Skip to Content
avatar image
Former Member

Error in Custom E-Sourcing Report

Dear all,

I would appreciate your inputs or sugggestions on an error I am receiving with a custom RFx Document Report. I get the error 'invalid column index' when I run the query in the preview mode or from the document.

Details of the Report:

We have a custom extension definition on the Rfx, which I am trying to query.

This is the query:

SELECT <%RESULTS%> FROM <%SCHEMA%>.FCI_RFX_DOC T1, <%EXT_TABLE(rfx.RFXDoc,CustomExtensionName)%> T2

WHERE T1.CONTEXTID = <%CONTEXT(rfx.RFXDoc)%> AND T2.PARENT_OBJECT_ID = T1.OBJECTID

It evaluates to:

SELECT T2.Ext_Field1, T2.Ext_Field2 FROM esource.FCI_RFX_DOC T1, esource.FCI_DYN_$2147483347 T2 WHERE T1.CONTEXTID = -2147483548 AND T2.PARENT_OBJECT_ID = T1.OBJECTID

Could you please let me know if you are able to identify the source of this error.

Thanks & Regards,

Reshma Varghese

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jun 24, 2009 at 02:06 PM

    Would suggest to run this SQL in SQL editor to verify if it is really an index issue on the column/table:

    SELECT T2.Ext_Field1, T2.Ext_Field2 FROM esource.FCI_RFX_DOC T1, esource.FCI_DYN_$2147483347 T2 WHERE T1.CONTEXTID = -2147483548 AND T2.PARENT_OBJECT_ID = T1.OBJECTID

    Also, if you still cannot proceed further pls. try this an check if it works:

    SELECT T2.Ext_Field1, T2.Ext_Field2 FROM esource.FCI_RFX_DOC T1, esource.FCI_DYN_$2147483347 T2 WHERE T2.PARENT_OBJECT_ID = T1.OBJECTID

    Good Luck

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kamalakar,

      Thanks for the tip. However, it ran fine in the SQL Editor.

      The error is on the E-Sourcing UI side only.

      Regards,

      Reshma

  • avatar image
    Former Member
    Jul 07, 2009 at 11:02 AM

    Hi all,

    This issue has been resolved with help from James.

    The problem was a missing '?' in the query to match the filter option set in the filter tab of the query definition.

    Regards,

    Reshma

    Add comment
    10|10000 characters needed characters exceeded