Skip to Content
avatar image
Former Member

'Operating system call recv failed (error no. 10054)'

Hi Gurus,

We get system log error 'Operating system call recv failed (error no. 10054)' almost daily in our systems(SCM and ECC)

SCM 4.1,Kernel 640,patch 101,oracle 9.2.0.8.0

ECC6.0,Kernel700,patch 185,oracle 10.2.0.4.0

if any one have the same log entry and worked on this? please post suitable solution.

log is

System Log:

|Q0I|Operating system call recv failed (error no. 10054)

Task................ 03128 / Dispatcher

Program name........

Problem class....... K SAP Web AS Problem

Development class... STSK

Further details for this message type

Module name......... ninti.c

Line................ 789

Error text.......... recv10054

Caller.............. NiPRead

Reason/called....... recv

Documentation for system log message Q0 I :

The specified operating system call was returned with an error.

For communication calls (receive, send, etc) often the cause of errors

are network problems.

It could also be a configuration problem at operating system level.

(file cannot be opened, no space in the file system etc.).

Additional specifications for error number 10054

Name for errno numbe WSAECONNRESET

Short text Connection reset by peer

No documentation available for error WSAECONNRESET

regards

nag

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 18, 2009 at 02:00 PM

    Hi,

    Please check the SAPNOTE "Note 559119 - Call disconnections in the syslog or dev_rd"

    With Regards,

    Saurabh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Please check the SAP NOTE "Note 559119 - Call disconnections in the syslog or dev_rd"

      Apply this note and restart, is ok now, PI works without problems, but the error persists

      Regards,

      Mary

  • Dec 17, 2014 at 02:53 PM

    I am getting the same error as a result of the following... Does anyone have a clue???

    I have a custom program that dynamically builds a variant with program 'A' then passes the values to a memory location named 'ABCD'. Then program 'A' calls a modifed copy of the 'Z_CP_UJD_TEST_PACKAGE' I will call program 'B'. In program 'B' the data in memory location 'ABCD' is read into the proper prompt fields of a created variable.The values are properly being read into program 'B' from the shared memory location 'ABCD'. The program crashes at the line 'AT SELECTION-SCREEN ON VALUE-REQUEST FOR PROMPT.' as the values in memory are not passed.  Suddenly the session is terminated (when running this on the front end or in debug) and no log entries are made.

    I know this sounds confusing, but it works great in all other environments... except for our sandbox system, which is a client copy of our production environment. In production, the process runs pulling into memory a rather large dataset (about 1200 accounts @ 10 bytes each) and processes it without issue. In the sandbox, I can only get up to 150 accounts to process at once. The buffer is set to match in both environments.

    Might anyone have any experience with this or any idea why the process might work in one environment, but not another? We are getting ready to upgrade our BW system from 7.02 to 7.4, so it is critical to get our sandbox fully operational.

    Thank you,

    Kurt Dukes

    Add comment
    10|10000 characters needed characters exceeded