Skip to Content
0
Former Member
Jun 17, 2009 at 12:28 PM

SAPscript editor is ignoring my changes

25 Views

I am in the process of editing a SAPscript form and I have made about 20 changes so far. I have only a couple left. I have been saving my changes and transporting them and everything has been working fine. However, I have two changes that are being completely ignored by the editor. On one line I am trying to have three underlined sections separated by tabs so I have the following code:

&ULINE(14)&,, &ULINE(14)&,,&ULINE(14)&

As you may notice, there is an extra space after the first tab (,,). I have tried to remove this space and the editor just keeps putting it back. I have tried removing the line and re-writing it and other things trying to trick the editor into removing it, but nothing works, it just keeps putting it back.

Also, I have some character formatting on one line and I simply want all the words to have the same character format so I use the following code (where <K> is the tag for the format I want):

<K>WORD1,,WORD2,,WORD3,,WORD4,,WORD5</K>

Whenever I leave the editor and come back into it, it changes this line to the following:

<K>WORD1,,WORD2,,WORD3,,</K>WORD4,,WORD5

*I know the ending tag is not </K> it is the same just without the K, but this forum won't let me post that.

It moves the ending tag behind the third word and I can not get the last two words to have the same format as the rest. I have tried adding and extra <K> after the the thrid word, just for use with the last two words, but when I leave the editor and come back in, it just removes my formatting for the last two words like I had never put it in.

It's like the editor has a mind of its own. This is VERY frustrating. Has anyone ever experienced anything like this? Does anyone have any suggestions?

Thanks.