Skip to Content
author's profile photo Former Member
Former Member

-24913,ERR_SERVICEDB: Cannot register service database instance

I'm trying now since a few hours to find out the cause of the above error.

I am installing a new Solaris 10 zone (as I did a hundred times before successfully). The installation starts nicely (as usual) but then fails just with

extracting: -r-xr-x---     46999968 2009-05-11 17:08:39 pgm/slowknl
checking unpacked archive... ok
error occured while executing /sapdb/programs/bin/dbmcli -R /sapdb/BIQ/db inst_reg -k /sapdb/BIQ/db
/sapdb/programs/bin/dbmcli -R /sapdb/BIQ/db inst_reg -k /sapdb/BIQ/db: ERR
/sapdb/programs/bin/dbmcli -R /sapdb/BIQ/db inst_reg -k /sapdb/BIQ/db: -24913,ERR_SERVICEDB: Cannot regist
er service database instance for /sapdb/BIQ/db
installation exited abnormally  at Tu, Jun 16, 2009 at 18:55:05

Users have been created as before, permissions are identical to other systems etc. I don't see a difference.

If I execute the same command as user root I'm getting the same error message.

What can be the problem?


Add comment
10|10000 characters needed characters exceeded

1 Answer

  • Best Answer
    Posted on Jun 16, 2009 at 05:48 PM

    Hello Markus,

    1. Please update the thread with the output of the following commands as root user:

    ls -l /etc/opt/sdb

    ls -l /sapdb/data

    ls -l /sapdb/data/config

    /sapdb/programs/bin/xinstinfo BIQ

    /sapdb/programs/bin/dbmcli db_enum -s

    /sapdb/programs/bin/dbmcli -R /sapdb/BIQ/db inst_reg -k /sapdb/BIQ/db

    ls -l /sapdb/data/wrk/dbmsrv*

    2. Please check the files /sapdb/data/wrk/dbmsrv<u2026>.prt, /sapdb/data/wrk/dbmsrv<u2026>.err

    & post additional information from those files.

    Thank you & best regards, Natalia Khlopina

    Edited by: Natalia Khlopina on Jun 16, 2009 10:53 AM

    Add comment
    10|10000 characters needed characters exceeded

    • Found the problem:

      biqual:sqdbiq 1% dbmcli dbm_version -s
      RTE_CallSdbStarter(): Current working directory does not exist or path is too long, errno is 13
      RTE_CallSdbStarter(): Cannot change to relative path /sapdb/BIQ/db/pgm
      RTE_CallSdbStarter(): No absolute path for: /sapdb/BIQ/db/pgm/dbmsrv
      Error! Connection failed to node (local) for database (no dbname):
      Reading header from pipe:(0:NO ERROR(0)

      The sqdbiq user was not permitted to read and step into /sapdb.

      I have NO CLUE why sapinst did not change the permissions of that directory.

      Neverless, it works now - thank you very much for your assistance and ideas what do check.