Skip to Content

SAP GUI for HTML Drop-down rendering

Dropdown menus are not rendering correctly for me in the SAP WebGUI. They do display correctly in the SAPGUI. I have tested with Personas 3 SP4 as well, and they display correctly in edit mode, but when I am in runtime mode, it still displays incorrectly. I have tried with both the webgui and personas services in the browser, and the behavior is the same with both.

Here is the dropdown in webgui:

And here it is in edit mode in personas:

Any suggestions? I am using Kernel 7.45 SP 315. SAP_BASIS 7.4 SP 10.

Thanks,

Owen

6f7co.png (30.9 kB)
1qxzp.png (10.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 14, 2016 at 10:09 PM

    Which browser are you using? Is it the most recent version?

    Any difference with alternate browsers, or do all of them behave the same?

    Add comment
    10|10000 characters needed characters exceeded

    • It looks like it works correctly in Edge and Chrome, but we use Internet Explorer as our company browser, and that is where the bug is. I am using IE 11.447, it is up-to-date.

  • Nov 15, 2016 at 04:38 PM

    I talked to the Personas team at SAP, and they said it was a known bug that is fixed in Kernel 745 SP 316. We will try updating that today and I will report back if it fixes the problem.

    Add comment
    10|10000 characters needed characters exceeded

    • Using Chrome (or even Edge) instead of IE is a good fix, and it has the advantage of getting significantly better performance too :)

      (yes, I understand it may not be an option if the mandated browser is IE)