Skip to Content
avatar image
Former Member

This application has failed to start because SapNi.dll was not found

On the advice, good advice, of Melanie and Lars, here is a new thread for my question.

I'm assisting with a migration of SAPDB, on Windows Server 2003, to MaxDB 7.6.xx on Solaris 10 SPARC.

I can connect to my SAP DB 7.3.0.35 using Database Manager 7.4.3.23 as superdba. Now I'm trying to use the dbmcli.

I go to the server and pop open a cmd prompt and try it via dbmcli:

dbmcli -d sdb -u superdba,<password>

And I get a Windows dialog box that says

This application has failed to start because SapNi.dll was not found. Re-installing the application may fix this problem.

Hello,

actually, the SUPERDBA user only has ONE valid password. Although he is able to perform admin tasks and to execute SQL statements, there are not two passwords for this user!

So if you are able to connect with that user with dbmcli and not with sqlcli or loadercli, there seems to be something wrong with your system/users. Maybe the user called SUPERDBA on your system is not really the SYSDBA but a 'normal' dbm user.

When you connect with that user with dbmcli, please execute the following commands:

sql_execute select user from dual

sql_execute select SYSDBA from dual

sql_execute select * from users

Can you also connect with user control with dbmcli? You might want to check the default password (control).

Regarding the ni.dll problem: If I understand that correctly, you installed Database Studio locally on your PC. Did you also install any othe MaxDB software on that server? When you try to use dbmcli to connect to a remote database, you'll have to specify the -n <hostname> option. Or did you get that dll error on the database server itself?

Database Studio cannot be used to administer databases of version 7.3. You'll have to use DBMGUI or dbmcli for that.

Best regards, Melanie

Hi Melanie, Thanks for the response.

I cannot use dbmcli at the moment. I get the Windows dialog box saying

This application has failed to start because SapNi.dll was not found. Re-installing the application may fix this problem.

I am using dmcli on the Windows 2003 Server with my SAP DB 7.3 installed. Here is the version of dbmcli that I'm using.

C:\sapdb\SDB\db\bin>dbmcli -V

OK

version,os,dbroot,logon,code,swap

"7.6.06","WIN32","C:\Program Files\sdb\7606",True,ASCII,2

I'm going to try to do what the error message tells me and uninstall and re-install my DB management applications.

Thanks,

Rich

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Jun 15, 2009 at 11:35 AM

    Hello Rich,

    please logon as administrator and run the tool sdbverify.

    It should be located in <independent_program_path>/bin

    This should tell us if something is wrong with your software installation.

    Best regards,

    Melanie

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Natalie,

      I'm having a hard time getting the code markup tags to work properly. It's lumping it all together in some really ugly code.

      I'm going to work on it for another minute before I post again. Any suggestions?

      Thanks,

      Rich

  • avatar image
    Former Member
    Jun 16, 2009 at 09:13 PM
    Server Utilities           c:/sapdb/programs                             7.7.06.09     32 bit    valid
    DB Analyzer                c:/sapdb/programs                             7.6.06.03     32 bit    valid
    PCR 7300                   c:/sapdb/programs                             7.3.00.35               valid
    PCR 7301                   c:/sapdb/programs                             7.3.01.09               valid
    PCR 7104                   c:/sapdb/programs                             7.1.04.43               valid
    MaxDB PHP Driver           c:/sapdb/programs                             7.6.06.03     32 bit    valid
    PCR 7240                   c:/sapdb/programs                             7.2.04.17               valid
    Synchronization Manager    c:/sapdb/programs                             7.6.06.03               valid
    Base                       c:/sapdb/programs                             7.7.06.09     32 bit    valid
    Redist Python              c:/sapdb/programs                             7.6.06.03     32 bit    valid
    JDBC                       c:/sapdb/programs                             7.6.05.06               valid
    Messages                   c:/sapdb/programs                             MSG 0.8215              valid
    ODBC                       c:/sapdb/programs                             7.6.06.03     32 bit    valid
    Database Kernel            c:/program files/sdb/7606                     7.6.06.03     32 bit    valid
    Database Kernel            c:/sapdb/programs/databasestudio/utilities    7.7.6.9                 valid
    Database Kernel            c:/sapdb/sdb/db                               7.3.00.35     32 bit    valid
    Loader                     c:/sapdb/programs                             7.6.06.03     32 bit    valid
    SQLDBC                     c:/sapdb/programs                             7.6.06.03     32 bit    valid
    PCR 7250                   c:/sapdb/programs                             7.2.05.24               valid
    
    
    xinstinfo
    IndepData           : C:\sapdb\data
    IndepPrograms       : C:\sapdb\programs
    
    dbmcli -s dbm_version
    OK
    VERSION    = 7.7.06
    BUILD      = DBMServer 7.7.06   Build 009-123-202-944
    OS         = WIN32
    INSTROOT   =
    LOGON      = True
    CODE       = UTF8
    SWAP       = full
    UNICODE    = YES
    INSTANCE   = (unknown)
    SYSNAME    = Windows Server 2003 family
    MASKING    = YES
    REPLYTREATMENT = none,zlib,auto
    SDBDBM_IPCLOCATION = C:\sapdb\data\wrk
    

    Edited by: Rich Evans on Jun 16, 2009 4:13 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 16, 2009 at 09:14 PM

    I removed the path's in my command line and it seemed to fix the issue. The code tags are touchy 😉

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 16, 2009 at 09:36 PM

    2. Was "SAP Utilities" database software package installed when you run the DB studio installation?

    Please check the DB studio installation log, if the package "SAP Utilities" was included to be installed.

    I don't see that it was. I had uninstalled the new version of MaxDB Database Studio (v 7.7.06.09) to try to get back to mybaseline.

    I have reinstalled MaxDB Database Studio and when it was complete it displayed the logfile. I didn't see "SAP Utilities" listed as one of the options. I performed a 'typical' client installation.

    I apologize if I've muddied this up further.

    I tested both again and I'm still having the same issues with the dbmcli and the DB Studio 7.7.

    When I test Authentication using DB Studio, it says "Neither SQL nor DBM sessions are possible"

    When I try the dbmcli -d sdb -u superdba,<password> I get the same Windows dialog box popup that says "This application has failed to start because SapNi.dll was not found. Re-installing the application may fix this problem."

    I searched in the "C:\sapdb\programs\pgm" directory again for SapNi.dll and it is not present.

    Again, all apologies for the cloudy waters I've created 😊

    Regards,

    Rich

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 18, 2009 at 02:43 PM

    For better or worse, I copied the sapni.dll file from C:\Program Files\SAPDB\SQLStudio to c:\sapdb\programs\pgm.

    I can now use dbmcli without getting the Windows Dialog box error.

    C:\Documents and Settings\resys>dbmcli -d sdb -u superdba,<password>
    dbmcli on sdb>version
    OK
    version,os,dbroot,logon,code,swap
    "7.3.0","WIN32","C:\SAPDB\SDB\DB",True,ASCII,2
    

    I re-opened SAP MaxDB Database Studio 7.7.06.09 and when I "Test Login" it says "DBM sessions are possible."

    So I click Finish to connect, but the Event Log Viewer says

    sql error
    -4004,Unknown table name:DBM_STATE
    

    I'm going to guess this has to do with me using DB Studio 7.7 on a SAPDB 7.3 database?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Rich,

      1. Are you SAP customer?

      Please start SDBSETUP to run the DB studio installation, select custom, then next.

      What the MAXDB software components did you see for the selection?

      Did you download the DB Studio 7.7. software from SAP market place?

      2. You could use the sapni.dll, version 7.4.3.23 < you posted that you have

      Database Manager 7.4.3.23>, to connect to SAP DB 7.3.0.35 using dbmcli.

      3. Please see the database documentation at http://maxdb.sap.com/doc/7_7/default.htm

      -> Tools -> Database Studio

      "With the Database Studio database tool you can manage SAP MaxDB databases of version 7.5 and higher."

      Please use the DBMGUI /SQLStudio tools for the database instance 7.3.0.35

      Thank you and best regards, Natalia Khlopina