Skip to Content
avatar image
Former Member

Running Database Studio without Administrator rights (Windows XP)

Hi,

I just installed Database Studio Version 7.7.06.09 on Windows XP. I want to use it to access a local and a remote SAP DB. With the user who installed it this works fine, but this user has administrator rights on the machine and I tend to not work with this user.

Rather I'd prefer to use a local user 'harmless' without administrator rights. But when harmless tries to start Database Studio I get an error

"Read preferences for user management failed"

When I check Preferences-> Database Studio -> User Management

I get a dialog with an error which does not allow me to do anything.

I'm also asked to check file um.properties in <user_home>/sdb/.DatabaseStudio/.metadata/.plugins/com.sap.sdb.tools.core

That file does not exist. It also does not exist for my user with admin rights, so I would not know what to enter in that file.

If you can tell me what to do to fix this this would be highly appreciated.

TIA,

Thomas

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jun 11, 2009 at 05:59 PM

    > I just installed Database Studio Version 7.7.06.09 on Windows XP. I want to use it to access a local and a remote SAP DB. With the user who installed it this works fine, but this user has administrator rights on the machine and I tend to not work with this user.

    >

    > Rather I'd prefer to use a local user 'harmless' without administrator rights. But when harmless tries to start Database Studio I get an error

    > "Read preferences for user management failed"

    Hi Thomas,

    I understand the wish to not having to use an windows administrative user account for using the DB Studio.

    What worked on my test instance was this:

    - add user "harmless" to the "SDB Operators" group

    - assign the "SDB Operators" group full access for the /sapdb/data folder.

    regards,

    Lars

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 11, 2009 at 07:02 PM

    Hello Thomas,

    On Microsoft Windows, Members of the SDB Operators group can manage databases without belonging to the Administrators or System groups.

    The SDB Operators special operating system user group is available as of SAP MaxDB version 7.7.

    Please read the document

    "Special Operating System User Group on Microsoft Windows"

    at SAP link

    http://help.sap.com/saphelp_maxdb77/helpdata/en/44/bbe0dc91407006e10000000a155369/frameset.htm ->

    ->Database Administration -> Managing Users ->

    Special Operating System User Group on Microsoft Windows

    Or

    At SAP MaxDB 7.7 Library ::

    http://maxdb.sap.com/doc/7_7/default.htm

    -> Database Administration -> Managing Users ->

    Special Operating System Users and Groups ->

    "Special Operating System User Group on Microsoft Windows"

    Thank you and best regards, Natalia Khlopina

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      thanks for the quick responses -- both were right in principle, I guess. I actually had harmless assigned to the SDB operators group before even posting here, but that did not help, so I thought it was not relevant and did not mention it, sorry.

      Changing the access rights to the folders mentioned in the first response did change something -- afterwards user harmless could see something in the preferences -> Database Studio -> User management dialog, but still could not operate the DB. There was a login problem at start up (unknown user/password combination), probably to the .umdb database, the error message did not tell.

      Since I had not invested too much work I decided to reinstall and to ensure that the assignment of harmless to SDB operators and setting the access right to the foldes was done before the installation of database studio.

      Now everything works like a charme.

      Thanks again,

      Thomas