Skip to Content
avatar image
Former Member

MaxDB instance not able to connect through DBM tool

Hello,

We are facing very critical problem. MaxDB database instance is not able to connect from Database Manager tool. I tried everything. DB instance is down.

I stopped apache ,DB instance then x_server. Then I started x_server , apache but when I 'm trying to connect MaxDB instance, getting "-4 connection refused". "Server refused the connection".

I checked everything User password are Ok(superdba, control). I tried by rebooting server too.

Could anybody please help me out if faced this problem.

Earlier everything working fine. But now It 's not able to connect through DBM tool.

Any help would of great help..

Tks

Anju

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 10, 2009 at 06:11 PM

    Hi Anju,

    Please post also xserver_*.prt located in /sapdb/data/wrk on the database server.

    And update with additional information:

    /sapdb/programs/bin/sdbregview -l

    /sapdb/programs/bin/dbmcli db_enum -s

    /sapdb/programs/bin/dbmcli inst_enum

    /sapdb/programs/bin/xinstinfo

    Thank you and best regards, Natalia Khlopina

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      Thanks you very much for your help. I corrected the problem. There was some permission problem.

      now it 's working fine. But there is another problem, now when I 'm linking this to my ECC sandbox system. I configured all settings in CSADMIN in ECC sandbox.

      But when I 'm running report RSCMST in Sandbox sysem it shows me some time difference -223 seconds.

      I checked time is OK in sandbox. But there is time difference on content server.

      Could you help me out how to correct time on content server. This is AIX 5.3.

      I checked from smitty but could you please post the steps..

      Tks

      Anju

  • Jun 10, 2009 at 03:37 PM

    Hi Anju,

    looks like you misentered the connection details.

    Please try the following to check where/what went wrong:

    - ping <hostname of db server>
     - x_ping -n <hostname of db server> -d <DBSID>
     - dbmcli -n <hostname of db server> -d <DBSID> -u superdba,<pw>

    regards,

    Lars

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Anju,

      please re-read what I wrote.

      I didn't ask you to run

      x_ping -n -d

      but instead

      x_ping -n <hostname of database server> -d <DBSID>

      You've to fill in the correct values for

      <hostname of database server>

      and

      <DBSID>

      regards,

      Lars